Bug 189716 - incomplete pup session block later yum updating
incomplete pup session block later yum updating
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Depends On:
  Show dependency treegraph
Reported: 2006-04-23 17:05 EDT by Phil Wirtz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-17 16:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Phil Wirtz 2006-04-23 17:05:54 EDT
Description of problem:I ran pup a couple of nights ago and had to shut down
before finished (large dl @ 56k) . next I used yum --update and only 15 of 250
so packages were updated, tried pup without updating again and rest of packages
were listed ran yum again this time they were also listed

Version-Release number of selected component (if applicable):
[none@localhost ~]$ rpm -q --whatprovides pup
no package provides pup

[root@localhost none]# yum --version
Loading "installonlyn" plugin

How reproducible: tried to but couldn't

Steps to Reproduce:
1.let pup start update but not finsh
2.run yum 
3.run pup again
Actual results:

Expected results:

Additional info:
Comment 1 Jeremy Katz 2006-04-24 13:26:45 EDT
Can you reproduce this?  I can't get it to happen in some quick testing here.

Were you running yum _immediately_ after exiting pup?
Comment 2 Paul Nasrat 2006-04-24 13:31:56 EDT
Sounds like the fcntl transaction lock is still present to me.
Comment 3 Phil Wirtz 2006-04-25 18:52:37 EDT
>Were you running yum _immediately_ after exiting pup?
no, yum was started after shutdown/restart . I may have forced pup to quit I
don't recall

possible contributing factor my ISP regularly disconnects me more or less at
random. sometimes yum will quit before connection is re-established having run
out of mirrors
Comment 4 Paul Nasrat 2006-07-17 16:08:24 EDT
If you manage to get a reliable reproducer please reopen.  As we can't reproduce
here I'm going to close.

Note You need to log in before you can comment on or make changes to this bug.