Bug 189720 - Packaging seems broken
Packaging seems broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-23 18:42 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 05:29:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2006-04-23 18:42:39 EDT
Description of problem:
This problem is really a non 32 bit problem. As you know, when you build mono,
the main packages are all installed in /usr/lib. The problem comes when packages
are built for FE whereby even if one specifies %define _libdir /usr/lib, spec
files end up in /usr/lib64/pkgconfig with binaries built also ending up in
/usr/lib64/<package>

Upshot - packages on non 32 bit platforms fail when you try to use them.

When I build from source and pass in --libdir=/usr/lib64, mono is correctly
installed into /usr/lib64. If I do the same for other packages (such as ikvm),
everything works happily. If I don't pass in the --libdir argument to the
configure script, packages are installed in /usr/lib, but they still work -
nothing gets put into /usr/lib64.

There is either something wrong with how mono is being packaged or how package
makefiles are ignoring libs. Given that I have no problem with the source code
versions, it looks like a package problem.

Could you please have a look into this and offer some advice? It's holding up
something like 7 packages!

Version-Release number of selected component (if applicable):
1.1.13-6
Comment 1 Paul F. Johnson 2006-05-05 18:10:30 EDT
Seems the problem is in that the makefile.am files have a problem. Some contain
a line like this

pkgconfigdir=$(prefix)/lib/pkgconfig

which obviously will put things in /usr/lib. However, on 64 bit systems, this
should really be /usr/lib64.

I've suggested a fix to the mono developers (it's simple enough to do)

1. Change the makefile.am bits to read

pkconfigdir=$(prefix)/$(libdir)/pkgconfig

2. Alter the configure script so that it exports libdir to be lib or lib64
depending on what is passed in on the --libdir switch (default, lib)

I'll leave this bug open for now, though I suppose it's really an upstream
problem rather than an FC package problem

Note You need to log in before you can comment on or make changes to this bug.