Bug 1897245 - pydeps fails to build with Python 3.10: ValueError: No such version: 3.10
Summary: pydeps fails to build with Python 3.10: ValueError: No such version: 3.10
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pydeps
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio T. sagitter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968865 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall F36FTBFS F36FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-12 15:39 UTC by Tomáš Hrnčiar
Modified: 2021-09-24 20:43 UTC (History)
6 users (show)

Fixed In Version: pydeps-1.10.3-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-24 20:43:33 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github thebjorn pydeps issues 95 0 None open Support Python 3.10 2021-07-11 10:15:30 UTC

Description Tomáš Hrnčiar 2020-11-12 15:39:55 UTC
pydeps fails to build with Python 3.10.0a2.

version = '3.10'

    def get_canonical_version(version):
    
        if version in long_versions:
            version = ".".join(version.split(".")[:2])
        elif version not in short_versions:
>           raise ValueError("No such version: {}".format(version))
E           ValueError: No such version: 3.10

/usr/lib/python3.10/site-packages/stdlib_list/base.py:26: ValueError

stdlib_list does not have entry for Python3.10. 

https://github.com/jackmaney/python-stdlib-list/blob/master/stdlib_list/base.py#L12

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01757239-pydeps/

For all our attempts to build pydeps with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/pydeps/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 15:23:52 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Fedora Update System 2021-04-08 01:00:21 UTC
FEDORA-2021-09dc3693d2 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-09dc3693d2

Comment 3 Fedora Update System 2021-04-08 01:00:24 UTC
FEDORA-2021-fb975bdae8 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-fb975bdae8

Comment 4 Fedora Update System 2021-04-08 19:05:37 UTC
FEDORA-2021-09dc3693d2 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-09dc3693d2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-09dc3693d2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-04-08 20:58:37 UTC
FEDORA-2021-fb975bdae8 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-fb975bdae8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-fb975bdae8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-04-16 14:34:27 UTC
FEDORA-2021-fb975bdae8 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2021-04-24 19:46:42 UTC
FEDORA-2021-09dc3693d2 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-04-24 20:06:55 UTC
FEDORA-2021-09dc3693d2 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Miro Hrončok 2021-06-04 20:14:00 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 12 Miro Hrončok 2021-06-07 22:58:41 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 13 Miro Hrončok 2021-06-08 11:19:50 UTC
*** Bug 1968865 has been marked as a duplicate of this bug. ***

Comment 14 Miro Hrončok 2021-06-15 20:22:37 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 15 Miro Hrončok 2021-07-07 11:17:51 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 16 Fedora Release Engineering 2021-07-11 04:22:08 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-01-07).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 17 Antonio T. sagitter 2021-07-11 10:12:17 UTC
pydeps is still incompatible with Python-3.10
I'm disabling all tests for now

Comment 18 Miro Hrončok 2021-07-12 12:46:40 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 19 Ben Cotton 2021-08-10 12:48:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 20 Ankur Sinha (FranciscoD) 2021-08-31 19:51:54 UTC
(In reply to Antonio T. sagitter from comment #17)
> pydeps is still incompatible with Python-3.10
> I'm disabling all tests for now

Would it help if we carried this patch in pydeps for the time being?

https://github.com/jackmaney/python-stdlib-list/pull/49

Comment 21 Antonio T. sagitter 2021-09-03 16:42:53 UTC
(In reply to Ankur Sinha (FranciscoD) from comment #20)
> (In reply to Antonio T. sagitter from comment #17)
> > pydeps is still incompatible with Python-3.10
> > I'm disabling all tests for now
> 
> Would it help if we carried this patch in pydeps for the time being?
> 
> https://github.com/jackmaney/python-stdlib-list/pull/49

I'm waiting for a reply from Luis because maintainer of 'python-stdlib-list' package


Note You need to log in before you can comment on or make changes to this bug.