Bug 189753 - preview is removed from tetex, but documentation remains packaged
preview is removed from tetex, but documentation remains packaged
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks: 189728
  Show dependency treegraph
 
Reported: 2006-04-24 08:51 EDT by Jonathan Underwood
Modified: 2013-07-02 19:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 04:08:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2006-04-24 08:51:36 EDT
Description of problem:
Following bug #168859, preview was removed from the tetex package. However, the
documentation files are still packaged in /usr/share/texmf/doc/latex/preview.

Version-Release number of selected component (if applicable):
tetex-doc-3.0-17

How reproducible:
Every time

Steps to Reproduce:
1. Install tetex-doc
2.
3.
  
Actual results:
Documentation for preview.sty is installed

Expected results:
No documentation for preview.sty

Additional info:
Comment 1 Jonathan Underwood 2006-04-25 14:59:17 EDT
Note: This is rather a problem for the AUCTeX rpm in Fedora Extras.
preview-latex now ships as part of AUCTeX, but we can't enable preview-latex as
it will install the preview documentation in the directory I mention above, and
so tetex and auctex rpms will stomp on each others files. This is therefore
blocking updating the auctex package to install preview. Your attention to this
would be very well received. :) 
Comment 2 Jindrich Novy 2006-04-27 05:48:55 EDT
Yes, thanks for pointing this out. I removed preview documentation from the
latest devel tetex.
Comment 3 Jonathan Underwood 2006-04-27 07:58:56 EDT
Jindrich - thank you. The question now is whether an update should be shipped
for FC5. On the one hand, this would seem silly, since a rather large rpm would
need to be downloaded just to remove those few files. However, if we ship the
updated auctex package from Extras, that will overwrite the files from
tetex-doc, and then when/if tetex-doc is updated I fear that will then remove
the files installed from auctex. What do you suggest?
Comment 4 Jindrich Novy 2006-04-27 08:16:03 EDT
I have many changes gathered since the FC5 release, mostly related to outdated
styles and Japanese support so that it's IMO the right time to release an update
for FC5 soon, what also resolves the problem with auctex.
Comment 5 Fedora Update System 2006-04-27 18:03:10 EDT
tetex-3.0-19.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Fedora Update System 2006-05-26 10:10:52 EDT
tetex-3.0-10.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Fedora Update System 2006-06-07 19:37:44 EDT
tetex-3.0-10.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.