Bug 1897583 - python-gattlib fails to build with Python 3.10: Py_SIZE= needs to be replaced with Py_SET_SIZE
Summary: python-gattlib fails to build with Python 3.10: Py_SIZE= needs to be replaced...
Keywords:
Status: CLOSED DUPLICATE of bug 1896382
Alias: None
Product: Fedora
Classification: Fedora
Component: python-gattlib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1896382
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-13 14:14 UTC by Tomáš Hrnčiar
Modified: 2020-11-14 17:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-14 17:53:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-13 14:14:43 UTC
python-gattlib fails to build with Python 3.10.0a2.

/usr/include/boost/python/object/make_instance.hpp:50:13: error: lvalue required as left operand of assignment
   50 |             Py_SIZE(instance) = offsetof(instance_t, storage);
      |             ^~~~~~~

https://docs.python.org/3.10/whatsnew/changelog.html#id11

bpo-39573: Convert Py_REFCNT() and Py_SIZE() macros to static inline functions. They cannot be used as l-value anymore: use Py_SET_REFCNT() and Py_SET_SIZE() to set an object reference count and size. This change is backward incompatible on purpose, to prepare the C API for an opaque PyObject structure.
https://bugs.python.org/issue39573

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01757487-python-gattlib/

For all our attempts to build python-gattlib with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-gattlib/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-14 17:53:00 UTC

*** This bug has been marked as a duplicate of bug 1896382 ***


Note You need to log in before you can comment on or make changes to this bug.