Bug 189759 - automount -vd is different than -v -d.
automount -vd is different than -v -d.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 09:33 EDT by Thomas Steudten
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 10:17:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Steudten 2006-04-24 09:33:25 EDT
Description of problem:

automount does not detect -d flag if called with combined flags like
-vd as -v -d.

Version-Release number of selected component (if applicable):


How reproducible:

automount -vd : no debugging messages
automount -v -d.: debugging messages shown.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
no debug messages shown with -vd

Expected results:
flags detected in combined mode like -vd for -v -d.

Additional info:
autofs-4.1.4-16.2.2
Comment 1 Jeffrey Moyer 2006-04-24 09:56:22 EDT
That's odd.  Are you starting the daemon by hand?  If you're specifying flags
for the automounter via the master map or the sysconfig file, you should use the
long versions, "--debug" and "--verbose".  However, the two options do the same
thing, so either will suffice.

Ian, do you want to take a look at this?
Comment 2 Thomas Steudten 2006-04-24 10:17:42 EDT
There're long version for the most gnu cmd options. 

Close this bug. Seems that automount gives very rare debug messages, so this
looks like this bug. kill automount gives the same output with "-vd" or "-v -d".
A message like "Debug enabled would be nice".
Comment 3 Jeffrey Moyer 2006-04-24 10:27:53 EDT
The debug logs are logged at level DEBUG, which means they won't appear in
/var/log/messages.  See http://people.redhat.com/jmoyer for more information on
configuring autofs for debugging.  It is quite apparent when debug output is
enabled!
Comment 4 Thomas Steudten 2006-04-24 11:55:55 EDT
Aaaargh, I don't like to query the source code, to find out, at which level the
debug messages are logged. The normal case is that -d don't forks and prints
debug output to stderr.
Why should the DEBUG output not appear in /var/log/messages? This is the case
for standard FC5 syslog.conf setup, because the min level is info.
However, the man page should point to that, that the debug output is send with
level DEBUG!

So, please add a notice to the man page for FC5.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.