Bug 189768 - RHEL4U3 x86 will not install on IBM x460
RHEL4U3 x86 will not install on IBM x460
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 10:50 EDT by Don Vanco
Modified: 2013-07-02 22:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-16 16:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Vanco 2006-04-24 10:50:30 EDT
Description of problem:
RHEL4U3 x86 will not install on IBM x460.  No driver for SAS controller found.


Version-Release number of selected component (if applicable):
Default boot kernel in RHEL4U3 x86

How reproducible:
Every time


Steps to Reproduce:
1. Attempt to install RHEL4U3 x86 on IBM x460 scaled across 2 chassis
2. Watch as it finds no storage controller.
3. Pull out hair, call IBM to no avail, enjoy as they blame Red Hat for the issue
4. Fall back to RHEL4U2 & required driver disk from IBM's site:
http://www-1.ibm.com/support/docview.wss?rs=0&dc=D400&q1=88726RU&uid=psg1MIGR-62897&loc=en_US&cs=utf-8&cc=us&lang=en

 
Actual results:
No install.  I can install x86_64 with no problem, but it does not scale across
multiple chassis as x86 does, and this is an 8-way scaled config in question


Expected results:
Drivers are _supposed_ to be in the base OS

Additional info:
None really.  If there's some "secret sauce" I'm missing I'd love to hear it -
but there's no data posted publicly that I can find that leads me to believe
it's not broken.
As an FYI - ALL firmware at latest rev.
Comment 1 Jason Baron 2006-04-24 11:50:07 EDT
indeed. we haven't included that driver due to stability concerns...as soon as
the driver is ready we will include it. thanks.
Comment 2 Konrad Rzeszutek 2006-04-25 11:51:00 EDT
Don,

A bit of history might clear things up. There are two drivers for the Adaptec
SAS 9410SAS controller: adp94xx and aic94xx.

The adp94xx is a standalone driver that Adaptec developed for years. It is what
you currently can download from IBM website.

The aic94xx is a driver that IBM, Adaptec and Red Hat have been working on that
has been integrated in mainline kernel. The reason for this work is that much of
the adp94xx code functionality was spread in the mainline kernel and used by
other drivers. No sense of putting in the adp94xx when much of the code is
replicated in the kernel. So to remove some of the duplicate code that other
drivers were using (LSI SAS for example), Adaptec decided that create a new
driver - aic94xx. And since 2.6 is different from 2.5 and 2.4 (which the adp94xx
driver can also support), some of the code logic changed as well.

With that history  in mind, Jason is correct in regards to the mainline driver
(aic94xx) stability concerns. During U3 cycle the aic94xx driver was tested for
inclusion and died in a flaming death. This was when the aic94xx just started
being integrated in mainline. Since then Adaptec/IBM has been working on the
mainline driver to make it work as best, or even better than the standalone
driver (adp94xx).

I am surprised to hear that the IBM link does not have the U3 driver, it
definitly should. Let me contact the IBM person responsible for it and see if
there has been a new tarball posted that somehow didn't show in "public" pages.

I will post my findings on this bug.
Comment 3 Don Vanco 2006-04-25 13:08:26 EDT
Thank you for the detail.  This will make it much easier to answer my customers
concern.
Comment 4 Konrad Rzeszutek 2006-05-01 12:17:31 EDT
The driver is being certified inside IBM. Not sure what that exactly means (as
in, is this Red Hat certification, or some other ones). Will get more details.
Comment 5 John Jarvis 2006-06-16 16:55:33 EDT
The adp94xx driver is included as part of the beta of RHEL 4.4 and barring any
unforeseen circumstances will be part of the final product.  The beta is
available for testing from RHN.  Red Hat does currently certify storage solutions.
Comment 6 Konrad Rzeszutek 2006-06-16 16:59:02 EDT
Closing bug and changing state to Next Release.

Note You need to log in before you can comment on or make changes to this bug.