Bug 189794 - Updated kernel packages (2080 & 2096) hungs on Intel RAID
Updated kernel packages (2080 & 2096) hungs on Intel RAID
Status: CLOSED DUPLICATE of bug 186842
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 14:34 EDT by Alexander Shiyan
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 11:23:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Shiyan 2006-04-24 14:34:30 EDT
Description of problem:

Currently I use initial FC5 kernel-smp package(2054), it work fine with my
motherboard ASUS P5WD2 with onboard Intel RAID. Because initial kernel does't
work with NVIDIA drivers, I want to upgrade to kernel-smp package from updates
(it is 2080 & 2096-builds). But it hung system on kernel init. Probably
device-mapper is broken in these kernels. Last messages on console is:
device-mapper: dm-stripe: Target length not divisible by chunk size
device-mapper: error adding target to table
device-mapper: reload ioctl failed: Invalid argument
Unable to determine geometry of file/device /dev/mapper/isw_bgchejihdh_HomeRAID0.
...
And halt with kernel panic on mount /dev/root and so on...

I think device-mapper is broken between 2054 and 2080 builds, because
on 2054 it is work fine:
[root@shc /]# /sbin/dmsetup table
isw_bgchejihdh_HomeRAID0p3: 0 271530630 linear 253:0 41062140
isw_bgchejihdh_HomeRAID0p2: 0 40965750 linear 253:0 96390
isw_bgchejihdh_HomeRAID0p1: 0 96327 linear 253:0 63
isw_bgchejihdh_HomeRAID0: 0 312592902 striped 2 256 8:0 0 8:16 0
VG1-LV2: 0 227475456 linear 253:3 40960384
VG1-LV1: 0 40960000 linear 253:3 384
VG1-LV0: 0 3014656 linear 253:3 268435840

Version-Release number of selected component (if applicable):
Linux shc.home 2.6.15-1.2054_FC5smp #1 SMP Tue Mar 14 16:05:46 EST 2006 i686
i686 i386 GNU/Linux
Kernels 2080 and 2096 are broken.

Additional info:
Disks in RAID is two identical new SATA-2 SAMSUNG HD080HJ.
I may provide additional info if need.
Comment 1 Alexander Shiyan 2006-04-27 04:17:46 EDT
I found one patch in kernel git-tree with patch for dm-stripe. This patch contain
this check. I think, it is incorrect patch and it must be removed (or modified)
from kernel...
http://www.kernel.org/git/?p=linux/kernel/git/stable/linux-2.6.16.y.git;a=commit;h=8ba32fde2c5be52865b2fd7e5e3752a46971fabe
Any comments?
Comment 2 Johannes Engel 2006-05-02 04:13:14 EDT
The dmraid-part of that is already fixed (thanks to Heinz Mauelshagen, see bug
#186842). The dmsetup-part is still open.
Comment 3 Alasdair Kergon 2007-01-10 11:23:20 EST
kernel patch was correct - userspace dmraid needed fixing - an fc5 update perhaps?

*** This bug has been marked as a duplicate of 186842 ***

Note You need to log in before you can comment on or make changes to this bug.