Bug 1898120 - python-ruamel-yaml-clib fails to build with Python 3.10: Has old C code pre-generated from Cython sources
Summary: python-ruamel-yaml-clib fails to build with Python 3.10: Has old C code pre-g...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-ruamel-yaml-clib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Alan Pevec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-16 13:04 UTC by Miro Hrončok
Modified: 2021-02-10 20:46 UTC (History)
5 users (show)

Fixed In Version: python-ruamel-yaml-clib-0.1.2-5.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-10 20:46:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-11-16 13:04:11 UTC
python-ruamel-yaml-clib fails to build with Python 3.10.0a2.

It is caused by old C code pre-generated from Cython sources.

A fixer is available at: https://src.fedoraproject.org/rpms/python-ruamel-yaml-clib/pull-request/1


For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01766805-python-ruamel-yaml-clib/

For all our attempts to build python-ruamel-yaml-clib with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-ruamel-yaml-clib/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-20 18:50:05 UTC
Since the fonts-rpm-macros require this, I am bumping the severity.

Error: 
 Problem: package fonts-rpm-macros-1:2.0.5-4.fc33.noarch requires python3-ruamel-yaml, but none of the providers can be installed
  - package python3-ruamel-yaml-0.16.6-4.fc34.x86_64 requires python3-ruamel-yaml-clib, but none of the providers can be installed
  - package python3-ruamel-yaml-0.16.6-4.fc33.x86_64 requires python(abi) = 3.9, but none of the providers can be installed
  - package python3-ruamel-yaml-clib-0.1.2-4.fc33.x86_64 requires python(abi) = 3.9, but none of the providers can be installed
  - package python3-devel-3.10.0~a2-1.fc34.x86_64 conflicts with python3 < 3.10.0~a2-1.fc34 provided by python3-3.9.0-1.fc34.x86_64
  - package python3-devel-3.10.0~a2-1.fc34.x86_64 conflicts with python3 < 3.10.0~a2-1.fc34 provided by python3-3.9.0-1.fc34.i686
  - cannot install the best candidate for the job

Comment 2 Ben Cotton 2021-02-09 16:11:59 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.


Note You need to log in before you can comment on or make changes to this bug.