Bug 1898158 - mod_wsgi fails to build with Python 3.10: fatal error: node.h: No such file or directory
Summary: mod_wsgi fails to build with Python 3.10: fatal error: node.h: No such file o...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_wsgi
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968842 (view as bug list)
Depends On:
Blocks: PYTHON3.10 F35BetaBlocker 1968786 1968842 1969203
TreeView+ depends on / blocked
 
Reported: 2020-11-16 14:43 UTC by Miro Hrončok
Modified: 2021-07-02 21:59 UTC (History)
13 users (show)

Fixed In Version: mod_wsgi-4.8.0-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-02 21:59:43 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github GrahamDumpleton mod_wsgi issues 687 0 None open mod_wsgi fails to build with Python 3.10: fatal error: node.h: No such file or directory 2021-06-09 15:13:01 UTC
Github GrahamDumpleton mod_wsgi pull 688 0 None open Attempt at Python 3.10 compatibility 2021-06-17 21:57:41 UTC

Description Miro Hrončok 2020-11-16 14:43:38 UTC
mod_wsgi fails to build with Python 3.10.0a2.

+ /usr/bin/make -O -j2 V=1 VERBOSE=1
/usr/lib64/httpd/build/vendor-apxs -Wl,-export-symbols-regex -Wl,wsgi_module -c -I/usr/include/python3.10 -DDYNAMIC_ANNOTATIONS_ENABLED=1 -DNDEBUG -D_GNU_SOURCE -D_GNU_SOURCE -D_GNU_SOURCE  -Wc,-O2 -Wc,-flto=auto -Wc,-ffat-lto-objects -Wc,-fexceptions -Wc,-g -Wc,-grecord-gcc-switches -Wc,-pipe -Wc,-Wall -Wc,-Werror=format-security -Wc,-Wp,-D_FORTIFY_SOURCE=2 -Wc,-Wp,-D_GLIBCXX_ASSERTIONS -Wc,-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -Wc,-fstack-protector-strong -Wc,-specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -Wc,-m64 -Wc,-mtune=generic -Wc,-fasynchronous-unwind-tables -Wc,-fstack-clash-protection -Wc,-fcf-protection -Wc,-fno-strict-aliasing  src/server/mod_wsgi.c src/server/wsgi_*.c -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld  -L/usr/lib64 -L/usr/lib64 -L/usr/lib64/python3.10/config  -lpython3.10 -lcrypt -lpthread -ldl  -lutil -lm -lm
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -DLINUX -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1   -I/usr/include/apr-1  -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fno-strict-aliasing -I/usr/include/python3.10 -DDYNAMIC_ANNOTATIONS_ENABLED=1 -DNDEBUG -D_GNU_SOURCE -D_GNU_SOURCE -D_GNU_SOURCE  -c -o src/server/mod_wsgi.lo src/server/mod_wsgi.c && touch src/server/mod_wsgi.slo
In file included from src/server/mod_wsgi.c:22:
src/server/wsgi_python.h:44:10: fatal error: node.h: No such file or directory
   44 | #include "node.h"
      |          ^~~~~~~~
compilation terminated.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01757168-mod_wsgi/

For all our attempts to build mod_wsgi with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/mod_wsgi/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-16 15:02:23 UTC
This seem to be related to the removal of the old parser: https://bugs.python.org/issue40939

Comment 2 Ben Cotton 2021-02-09 15:25:09 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 3 Miro Hrončok 2021-06-04 20:13:06 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 4 Miro Hrončok 2021-06-07 16:10:28 UTC
This blocks freeipa-server.

package freeipa-server-4.9.4-1.fc35.1.x86_64 requires python3-mod_wsgi, but none of the providers can be installed

Comment 5 Miro Hrončok 2021-06-07 22:58:00 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 6 Miro Hrončok 2021-06-08 11:17:42 UTC
*** Bug 1968842 has been marked as a duplicate of this bug. ***

Comment 7 Petr Viktorin 2021-06-11 11:23:27 UTC
Here's a proposed patch, which I smoke-tested in a container: https://github.com/GrahamDumpleton/mod_wsgi/pull/688

Beware: before I started this patch, I didn't know anything about Apache internals and how to test them. Don't put this in production.

Comment 8 Fedora Blocker Bugs Application 2021-06-14 08:50:08 UTC
Proposed as a Blocker for 35-beta by Fedora user abbra using the blocker tracking app because:

 Prevents FreeIPA server from being installed, thus violating Fedora Server criteria: https://fedoraproject.org/wiki/Basic_Release_Criteria#FreeIPA_server_requirements

Comment 9 Miro Hrončok 2021-06-15 20:22:52 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 10 Adam Williamson 2021-06-17 21:57:43 UTC
I'm marking this ASSIGNED because it is being looked at upstream and FreeIPA depends on this so we don't want to package to be retired. Either I or one of the FreeIPA team will likely follow the upstream progress on this and merge it when it's ready.

Comment 11 Miro Hrončok 2021-06-17 23:02:17 UTC
We don't want this retired, but we might want to get it orphaned.

Comment 12 Miro Hrončok 2021-06-18 09:32:51 UTC
Anyway, there is a PR in https://src.fedoraproject.org/rpms/mod_wsgi/pull-request/9

Comment 13 Jan Pazdziora 2021-06-19 14:00:10 UTC
FreeIPA on Fedora rawhide now installs and runs fine, so mod_wsgi is generally working fine. Thanks!

Comment 14 Adam Williamson 2021-07-02 21:59:43 UTC
Yeah, we can close this, I think. The remaining issue discusssed in the PR isn't breaking FreeIPA and isn't release blocking AFAICS.


Note You need to log in before you can comment on or make changes to this bug.