Bug 18983 - Gcc crashes when compiling glibc
Summary: Gcc crashes when compiling glibc
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-12 18:00 UTC by jfm2
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-13 08:20:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jfm2 2000-10-12 18:00:46 UTC
When rebuilding the  glibc RPM with --target=i686 gcc 2.96 core dumps 
(illegal instruction) during the compilation of the sun_rpc directory.  It
is very reproducible and it happens both with the original and the patched
glibc you issued a few days ago.

The distribution is vanilla RedHat 7 where everything has been installed,
glibc was the original one.  The RPM builds successfully when targetting
386

My box has a K6/2 processor

Comment 1 Jakub Jelinek 2000-10-12 19:18:56 UTC
Details please, which file does it crash on, which options passed to it,
preprocessed file (best run rpm -ba glibc.spec 2>&1 | tee glibc.log,
then cut'n'paste the command which caused the gcc to crash, add
-save-temps -v to it and send me its output and the .i file).
I cannot reproduce this myself and I'm building glibc with these
flags (both i386 and i686 targets) almost daily for a couple of
months.

Comment 2 Jakub Jelinek 2000-10-13 08:20:46 UTC
Actually, why are you building i686 glibc on K6/2? K6/2 AFAIK does not have
conditional move instructions, so if the SIGILL comes when glibc tries to
run rpcgen or similar program, it can crash on K6/2 if there are any
cmoves generated (which gcc can legally use if -march=i686).
During glibc bootstrap after the main library is compiled glibc executes
binaries using the newly built dynamic linker and library.

Comment 3 jfm2 2000-10-13 21:09:25 UTC
It turned to be a mistake.  Somewhere in the the building of glibc an auxilary
program is byuilt and executed.  Since that executable was generated with the
PPro instruction set and I was on a K6/2 it core
dumped and I thought it was the compiler who had core dumped.


Note You need to log in before you can comment on or make changes to this bug.