Bug 1898303 - E2E test: Use KUBEADM_PASSWORD_FILE by default
Summary: E2E test: Use KUBEADM_PASSWORD_FILE by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 4.5.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1898302
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-16 18:51 UTC by OpenShift BugZilla Robot
Modified: 2021-01-20 05:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-20 05:49:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 7228 0 None closed [release-4.5] Bug 1898303: Use KUBEADM_PASSWORD_FILE by default 2021-01-13 07:25:22 UTC
Red Hat Product Errata RHBA-2021:0033 0 None None None 2021-01-20 05:49:51 UTC

Description OpenShift BugZilla Robot 2020-11-16 18:51:36 UTC
+++ This bug was initially created as a clone of Bug #1898289 +++

Symptomatic Behavior

Pre-4.7 console tests are using hardcoded kubeadmin password location
Expected Behavior

They should use KUBEADM_PASSWORD_FILE

We need to backport https://github.com/openshift/console/pull/7075 to release-4.6 and earlier. We will likely need a BZ for this.

Impact

Blocks openshift_installer_src deprecation

Category

CI Jobs

Comment 5 Yadan Pei 2021-01-13 07:37:01 UTC
https://github.com/openshift/console/blob/release-4.5/test-prow-e2e.sh#L20 shows

BRIDGE_KUBEADMIN_PASSWORD="$(cat "${KUBEADMIN_PASSWORD_FILE:-${INSTALLER_DIR}/auth/kubeadmin-password}")" 

BRIDGE_KUBEADMIN_PASSWORD comes from KUBEADMIN_PASSWORD_FILE by default

Moving to VERIFIED

Comment 7 errata-xmlrpc 2021-01-20 05:49:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.27 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0033


Note You need to log in before you can comment on or make changes to this bug.