Bug 189831 - dmsetup remove_all does not work
Summary: dmsetup remove_all does not work
Status: CLOSED DUPLICATE of bug 189832
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-24 22:55 UTC by Dinesh Surpur
Modified: 2010-01-12 02:25 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-05-22 21:52:06 UTC


Attachments (Terms of Use)

Description Dinesh Surpur 2006-04-24 22:55:50 UTC
Description of problem:

I am running RH4 U3 and when i issue dmsetup remove_all i do not see the 
device links removed from /dev/mapper/<MP Device>. dmsetup table shows the 
devices were removed and /var/log/messages also shows the device removed. 
Issuing multipath -F does not help.  

Version-Release number of selected component (if applicable):
RH4 U3
# rpm -qa | grep -i device
device-mapper-1.02.02-3.0.RHEL4
device-mapper-multipath-0.4.5-12.0.RHEL4

How reproducible:
1. Export the storage volumes to the host
2. Issue "echo "scsi add-single-device"" to add the device to the scsi layer
3. issue multipath command (i had disablad user_friendly_names)
The following /etc/multipath.conf was used
defaults {
        udev_dir                /dev
        polling_interval        10
        selector                "round-robin 0"
        path_grouping_policy    multibus
        getuid_callout          "/sbin/scsi_id -g -u -s /block/%n"
        prio_callout            /bin/true
        rr_min_io               100
        rr_weight               priorities
        failback                immediate
        user_friendly_names     no
}

devnode_blacklist {
       wwid 26353900f02796769
        devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
        devnode "^hd[a-z]"
        devnode "^cciss!c[0-9]d[0-9]*"
        devnode "sda"
}

devices {
       device {
               vendor                  "3PARdata"
               product                 "VV"
               path_grouping_policy    multibus
               path_checker            tur       
               no_path_retry           60
        }
}

4. ls  /dev/mapper
control 350002ac00d58003e 350002ac00d58003e1

5. dmsetup remove_all

From /var/log/messages
multipathd: dm map 350002ac00d58003e removed

6. ls /dev/mapper
control 350002ac00d58003e 350002ac00d58003e1 -- I still see the link

7. multipath -F 
# ls /dev/mapper
control 350002ac00d58003e 350002ac00d58003e1 -- I still see the link

8. dmsetup
dmsetup table
No devices found 

9. cat /proc/partitions -- shows no dm devices.

Things work correctly if dmsetup remove <device> is used. 

This is also causing issues when you use kpartx command it is not adding the 
partition existed on the device with the following error:

Apr 24 14:42:13 sqa-dell2850-01 hal.hotplug[16195]: timout(10000 ms) waiting 
for /block/dm-20
Apr 24 14:42:13 sqa-dell2850-01 hal.hotplug[16200]: timout(10000 ms) waiting 
for /block/dm-20

There is no /dev/dm-20 created

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Alasdair Kergon 2006-05-22 21:52:06 UTC

*** This bug has been marked as a duplicate of 189832 ***


Note You need to log in before you can comment on or make changes to this bug.