Bug 1898498 - system upgrade blocked by python2-fedora (duplicate obsoletes)
Summary: system upgrade blocked by python2-fedora (duplicate obsoletes)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-fedora
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1903289 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-17 10:41 UTC by Remi Collet
Modified: 2020-12-05 01:15 UTC (History)
6 users (show)

Fixed In Version: python-fedora-1.1.0-3.fc33 python-fedora-1.1.1-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-05 01:15:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Remi Collet 2020-11-17 10:41:25 UTC
Nov 17 09:54:40 builder dnf[1223]: Error :
Nov 17 09:54:40 builder dnf[1223]: Problème: both package python3-fedora-1.1.0-2.fc33.noarch and fedora-obsolete-packages-33-28.noarch obsolete python2-fedora < 0.10.0-11
Nov 17 09:54:40 builder dnf[1223]:  - conflicting requests

So system upgrade fails during the "dnf system-upgrade reboot" phase, and explanation is not so easy to find...


The workaround is to remove python2-fedora before the upgrade.

Comment 1 Miro Hrončok 2020-11-17 17:08:12 UTC
fedora-obsolete-packages-33-28.noarch is part of the Fedora repo. Even if we remove the obsoletes in a newer version, the 33-28 version will remain in the Fedora repo. It cannot be removed.

python3-fedora-1.1.0-2.fc33.noarch is part of the Updates repo and hence can be replaced by an updated version that does not have the obsoletes.


The Obsoletes were introduced in https://src.fedoraproject.org/rpms/python-fedora/c/7add8a027e8acf8d7bfc2ad6b1442cace8c71d70?branch=master as an attempted fix of bz1605204. However, at that point, the obsoletes already existed in fedora-obsolete-packages and the bugzilla remained open only for the problem on Fedora 31(which, despite the bugzilla now CLOSED, was not actually fixed, but I guess nobody cares about Fedora 31 now).

Please, remove the Obsoletes from python3-fedora (and don't add them back) in Fedora 32+.

Comment 2 Fedora Update System 2020-11-19 22:38:13 UTC
FEDORA-2020-8e0ef661af has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-8e0ef661af

Comment 3 Fedora Update System 2020-11-19 22:38:13 UTC
FEDORA-2020-05ae9b214a has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-05ae9b214a

Comment 4 Fedora Update System 2020-11-20 02:15:24 UTC
FEDORA-2020-8e0ef661af has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-8e0ef661af`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-8e0ef661af

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-11-20 02:17:05 UTC
FEDORA-2020-05ae9b214a has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-05ae9b214a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-05ae9b214a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-11-22 01:25:04 UTC
FEDORA-2020-8e0ef661af has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-11-27 02:18:42 UTC
FEDORA-2020-a4ed03c5d5 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a4ed03c5d5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a4ed03c5d5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Miro Hrončok 2020-12-01 20:26:14 UTC
*** Bug 1903289 has been marked as a duplicate of this bug. ***

Comment 9 Miro Hrončok 2020-12-01 20:55:48 UTC
Switching back to ON_QA because the F32 upgrade is still in testing.

Comment 10 Fedora Update System 2020-12-05 01:15:32 UTC
FEDORA-2020-a4ed03c5d5 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.