This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 18985 - Segfault in libSM
Segfault in libSM
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 14:01 EDT by Tim Waugh
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-16 13:02:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Here is a stack trace. (7.93 KB, text/plain)
2000-10-18 15:40 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2000-10-12 14:01:52 EDT
I'm not sure what the correct component for this is.

I have a reproducible crash here.  It happens when I log out from a GNOME
session that was started from a remote X display.  I.e. I have kdm set to
respond to XDMCP, and I have another machine running "X -query
$kdm_machine", which I log in using, and when I log in I use GNOME.

Logging out causes gnome-session to crash, and the stack ends up in libSM.

I can dig up a stack trace if you like.  It would be nice to know if it's
just me or if someone can reproduce it.
Comment 1 Tim Waugh 2000-10-12 14:04:32 EDT
Oh yeah, and it only seems to happen if I use 'Ctrl-Alt-Delete' to logout. 
Logging out via the menus seems to work fine.
Comment 2 Tim Waugh 2000-10-12 16:29:34 EDT
Specifically, it's when I select 'No' or 'Help' when asked if I really want to
log out.

More info: I don't see this problem when I'm using the kdm machine, only when
I'm using a remote X terminal machine (also running Red Hat Linux 7).
Comment 3 Tim Waugh 2000-10-18 15:40:45 EDT
Created attachment 4368 [details]
Here is a stack trace.
Comment 4 Tim Waugh 2000-10-18 16:11:43 EDT
Okay, this looks like a gnome-session bug to me now.
Comment 5 Owen Taylor 2000-11-16 11:53:45 EST
I'm confused by the references above to both hitting Ctrl-Alt-Backspace
and logging out.... (Ctrl-Alt-Backspace is a rude termination of the
session, not logging out.)

What is the exact sequence of steps that triggers the problem?

Does it happen if you login locally with KDM instead of via XDMCP?
What if you use XDM or GDM instead of KDM?
Comment 6 Tim Waugh 2000-11-16 12:03:05 EST
Sorry, I meant Ctrl-Alt-Delete.

The exact sequence is:

Login via XDMCP.
Ctrl-Alt-Delete
Hit 'Yes'. (Or 'no', it doesn't actually seem to make a difference..)

When I log in locally, not via XDMCP, this doesn't happen.
Comment 7 Owen Taylor 2000-11-16 12:35:14 EST
Ah. Asking around ,the binding of Ctrl-Alt-delete to logout was in 
some of our betas but didn't make it into the final 7.0, either inadvertently
or intentionally - its not clear. If you are running 7.0-final,
the binding may have migrated into your ~/.sawfish-custom if you
edited other key bindings.

Anyways, it should work. I guess I'll try setting up KDM for XDMCP
(though not this week) and see if I can reproduce it.
Comment 8 Tim Waugh 2000-11-16 13:02:57 EST
I just installed a machine with 7.0-i386-respin-disc1, and Ctrl-Alt-Delete is
bound to logout. :-/
Comment 9 Owen Taylor 2001-08-03 16:11:16 EDT
Seems to be fixed since 7.0 - log in (to GDM) via XDCMP,
Ctl-Alt-Del to logout, yes/no work fine.

Note You need to log in before you can comment on or make changes to this bug.