Bug 189851 - [bn] Translated shortcuts are not uniform
[bn] Translated shortcuts are not uniform
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeprintui (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ankit Patel
bzcl34nup
: Translation
Depends On:
Blocks: Indic 222619
  Show dependency treegraph
 
Reported: 2006-04-25 02:28 EDT by A S Alam
Modified: 2013-07-02 20:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 07:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shortcut key (28.92 KB, image/png)
2006-04-25 02:38 EDT, A S Alam
no flags Details
Bug is still existing. (35.58 KB, image/png)
2007-01-15 05:26 EST, Mayank Jain
no flags Details
Screenshot of fixed application (96.60 KB, image/png)
2008-05-06 07:23 EDT, A S Alam
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 339669 None None None Never

  None (edit)
Description A S Alam 2006-04-25 02:28:13 EDT
Description of problem:
Some shortcuts (Alt+) are translated in Bengali, but Some are in English.

Version-Release number of selected component (if applicable):
gedit-2.14.2-1.fc5.1

How reproducible:
Everytime

Steps to Reproduce:
1.LANG=bn_IN.UTF-8 gedit
2.Check Toolbar 
3.
  
Actual results:
 First Icon has Translated, but 4th is in English (Print)

Expected results:
All Shortcut key should be English only or Translated 

Additional info:
Gedit is getting Translation from following files
/usr/share/locale/bn/LC_MESSAGES/glib20.mo
/usr/share/locale/bn/LC_MESSAGES/gtksourceview-1.0.mo
/usr/share/locale/bn/LC_MESSAGES/libgnome-2.0.mo
Comment 1 A S Alam 2006-04-25 02:38:33 EDT
Created attachment 128180 [details]
shortcut key
Comment 2 A S Alam 2006-04-25 02:41:10 EDT
addition Translation Files:

/usr/share/locale/bn/LC_MESSAGES/gtk20.mo
/usr/share/locale/bn/LC_MESSAGES/gtk20-properties.mo
Comment 3 A S Alam 2006-04-25 03:16:00 EDT
as Other Indic Langauges (Gujarati, Hindi, Punjabi) are using "English" Shortcuts, 
So English shortcuts are Recommend
Comment 4 Matthias Clasen 2006-09-30 09:48:41 EDT
The important bit here is that "shortcuts" must be characters that can actually
be typed on typical keyboards used for the language, since it doesn't work to have 
shortcuts with characters that can only be entered via input methods.
Comment 5 Mayank Jain 2007-01-15 04:50:32 EST
Adding the Bengali LM to the CC list.
Comment 6 A S Alam 2007-01-15 05:17:41 EST
Press Ctrl+P (or Print from menu), then check Location->Default-> able to see 2
shortcut keys still in Bengali, don't know gedit or gtk+ issue
Comment 8 Mayank Jain 2007-01-15 05:26:44 EST
Created attachment 145561 [details]
Bug is still existing.

gtk-print?
Comment 9 Mayank Jain 2007-01-15 05:41:34 EST
Checked up gedit-print.[ch] and found this...

#include <libgnomeprintui/gnome-print-dialog.h>

Wrong translations are coming from libgnomeprintui package.
Comment 10 Matthias Clasen 2007-03-29 12:19:52 EDT
There is nothing any of us (desktop team) can do about wrong bn translations.
Any fixes here need to come from the i18n side.
Comment 11 Runa Bhattacharjee 2007-03-29 23:46:32 EDT
I am not sure if the bug is for bn or bn_IN. The steps to reproduce suggest the
latter. In that case the translations for libgnomeprintui for bn_IN does not
contain any bn characters as shortcut keys. I suspect (and the translated UI
text suggest as well) that in this case bn translations are being used  instead
of bn_IN.
Comment 12 Chester Cheng 2007-04-27 10:38:52 EDT
The translation looks fine to me in RHEL5 Client.
Does the problem solved, Runa?
Comment 13 Runa Bhattacharjee 2007-04-30 01:13:14 EDT
Not really chester. Instead of the bn_IN translations the bn translations (that
contain the bengali shortcuts) are being used in the bn_IN locale. 

The bn_IN translations are here:

http://l10n.gnome.org/POT/libgnomeprintui.gnome-2-12/libgnomeprintui.gnome-2-12.bn_IN.po

but the libgnomeprintui-2.2.mo file does not exist in
/usr/share/locale/bn_IN/LC_MESSAGES
Comment 14 Tamal Kanti Nath 2007-10-23 03:00:49 EDT
I have found that only "incremental search" menu item is written in English.
Rest are in Bengali.
Comment 15 Bug Zapper 2008-04-03 13:13:08 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 16 Jens Petersen 2008-04-30 20:40:44 EDT
Is this still a problem?
Comment 17 A S Alam 2008-05-06 07:23:10 EDT
Created attachment 304624 [details]
Screenshot of fixed application

Note You need to log in before you can comment on or make changes to this bug.