Bug 1898662 - Xen hypervisor wont boot "with not an elf binary" on kernel 5.9.8
Summary: Xen hypervisor wont boot "with not an elf binary" on kernel 5.9.8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Young
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-17 18:25 UTC by Brandon
Modified: 2020-12-03 01:41 UTC (History)
3 users (show)

Fixed In Version: xen-4.13.2-4.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-03 01:41:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Brandon 2020-11-17 18:25:50 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Xen 4.13.2-1
Kernel 5.9.8-100

How reproducible:
Install xen latest and kernel latest and set up fedora as Dom0.


Actual results:
Dom0 will not boot with "not an elf binary"

Expected results:
Dom0 boots

Additional info:
Switched to kernel 5.8.18-200 and boot was successful

Comment 1 Michael Young 2020-11-17 19:27:50 UTC
I was wondering how long it would be before someone else noticed that. The issue is that Fedora's 5.9 kernels are compressed by zstd instead of gzip and xen doesn't support zstd decompression. I have been looking at what is required to add zstd support into xen but it is still work in progress and I don't know how successful I will be.

Comment 2 Brandon 2020-11-17 20:31:11 UTC
I noticed a very similar report in Arch around the compression, but couldn't find anything specific about fedora chaging the compression.  I'm wondering if the arch folks figured out how to get zstd into the xen loader.

Comment 3 Fedora Update System 2020-11-23 23:42:22 UTC
FEDORA-2020-c55b07ef76 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c55b07ef76

Comment 4 Fedora Update System 2020-11-24 02:21:03 UTC
FEDORA-2020-c55b07ef76 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c55b07ef76`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c55b07ef76

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-11-25 01:19:52 UTC
FEDORA-2020-4ff32ef9be has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-4ff32ef9be`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4ff32ef9be

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-12-03 01:41:43 UTC
FEDORA-2020-4ff32ef9be has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.