Bug 1898818 - GNOME (Wayland) freezes after the recent kernel rollout (5.8.18 -> 5.9.8)
Summary: GNOME (Wayland) freezes after the recent kernel rollout (5.8.18 -> 5.9.8)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 33
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-18 07:26 UTC by Eivind Leversund
Modified: 2021-01-16 12:34 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-16 12:34:50 UTC
Type: Bug


Attachments (Terms of Use)
Kernel logs for 5.9.8-200 boot-up (97.08 KB, text/plain)
2020-11-18 07:26 UTC, Eivind Leversund
no flags Details

Description Eivind Leversund 2020-11-18 07:26:17 UTC
Created attachment 1730486 [details]
Kernel logs for 5.9.8-200 boot-up

1. Please describe the problem:

After kernel 5.9 was rolled out to Fedora Silverblue 33 a few days ago I started experiencing desktop freezes. Intermittent, sometimes it would hang for just a few minutes, other times much longer, and then become usable again. I don’t see any obvious error messages reported when running journalctl.

I downgraded the kernel to see if I could isolate the problem following [these instructions](https://discussion.fedoraproject.org/t/downgrading-kernel-on-silverblue/1928), and I am now typing this on the following version, *without freezing issues*:

    ● ostree://fedora:fedora/33/x86_64/silverblue
                       Version: 33.20201117.0 (2020-11-17T00:48:12Z)
                    BaseCommit: 7b002133773c2630d79d8838bb96e2d7090a80a4903ee5439bd5a62aed1efc07
                  GPGSignature: Valid signature by 963A2BEB02009608FE67EA4249FD77499570FF31
           RemovedBasePackages: firefox 82.0.3-1.fc33
          ReplacedBasePackages: kernel-core kernel-modules-extra kernel-devel kernel-modules kernel 5.9.8-200.fc33 -> 5.8.18-300.fc33, kernel-headers 5.9.7-200.fc33 -> 5.8.18-300.fc33
               LayeredPackages: crit elementary-videos emacs fedora-workstation-repositories
                                ifuse libimobiledevice-devel libimobiledevice-utils
                                libplist-python syncthing virt-manager


2. What is the Version-Release number of the kernel:

5.9.8-200.fc33


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

It worked before the roll-out of 5.9.8-200.fc33, then the release number was 5.8.18-300.fc33.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

It happens whenever I am logged into the desktop (Gnome on Wayland). I have not tried Gnome on X11, though. I have not seen any special pattern regarding which applications I run. I run a mix of RPM based and flatpak applications (which is the preferred way for desktop apps in Silverblue).

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Well, these instructions won't work as-is in Silverblue ;-) But I know what to do, so I'll post update after trying it out :-)


6. Are you running any modules that not shipped with directly Fedora's kernel?:

No special modules.


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Attached

Comment 1 Eivind Leversund 2020-11-18 14:04:38 UTC
I had to re-purpose the external monitor to be used in the home-office setup, so I no longer have an external monitor connected to my laptop.
 
So: while preparing the ostree deploys for running the rawhide kernel, I booted the 5.9 kernel again - and the freezes are now gone! 

Seems like the freezes were related to using the external monitor with the new 5.9 kernel.

I am afraid that I will have very limited/sporadic opportunity to try out other kernels on my laptop with external monitor, so I suggest you put this bug report on the back-burner for now.

Comment 2 Eivind Leversund 2021-01-16 12:34:50 UTC
I got some test-time with the monitor again around 5.9.11 roll-out, and did not experience any issues. Later, I started using another external monitor, also without problems. 

I am not familiar with the terms - is NOTABUG the right one when closing this? It seems like it got fixed in a later point release, however I didn't isolate it to anything specific.


Note You need to log in before you can comment on or make changes to this bug.