Bug 189888 - perl-Net-Server-0.93-1.fc5 breaks amavisd-new.
perl-Net-Server-0.93-1.fc5 breaks amavisd-new.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: amavisd-new (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 11:27 EDT by Kazutoshi Morioka
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.4.0-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 16:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazutoshi Morioka 2006-04-25 11:27:38 EDT
Description of problem:
perl-Net-Server-0.93-1.fc5 breaks amavisd-new.

mailq shows:
(host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=08431-01,
 parts_decode_ext FAILED: parsing file(1) results - missing last 1 results at
 (eval 41) line 154. (in reply to end of DATA command))

from /var/log/maillog:
Apr 26 00:02:01 myhost amavis[8525]: (08431-01) run_command: child process
[8525]: Error closing main::stdin: \344\270\215\346\255\243\343\201\252\343
\203\225\343\202\241\343\202\244\343\203\253\350\250\230\350\277\260\345\255
\220\343\201\247\343\201\231 at /usr/sbin/amavisd line 1872.\n
Apr 26 00:02:01 myhost amavis[8431]: (08431-01) TROUBLE in check_mail: 
parts_decode_ext FAILED: parsing file(1) results - missing last 1 results at 
(eval 41) line 154.
Apr 26 00:02:01 myhost amavis[8431]: (08431-01) PRESERVING EVIDENCE in 
/var/spool/amavisd/tmp/amavis-20060426T000201-08431
Apr 26 00:02:01 myhost postfix/smtp[8524]: 0896133167: 
to=<morioka@myhost.example.com>, orig_to=<morioka>, relay=127.0.0.1[127.0.0.1],
delay=1, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in
processing, id=08431-01, parts_decode_ext FAILED: parsing file(1) results - 
missing last 1 results at (eval 41)
line 154. (in reply to end of DATA command))

abobe "\344\270\215..." is UTF-8 message in japanese ”不正なファイル記述子です".
This means "Bad file descriptor".

I downgraded to old perl-Net-Server-0.90-2.fc5, and amavisd-new works again.

Version-Release number of selected component (if applicable):
perl-5.8.8-4
perl-Net-Server-0.93-1.fc5
amavisd-new-2.3.3-5.fc5
postfix-2.2.8-1.2

How reproducible:
always

Steps to Reproduce:
1.Setup Postfix and Amavisd-new.
2.Send a mail
3.mailq
  
Actual results:
mail is defferd by error.

Expected results:
mail is sent.

Additional info:
Comment 1 Kazutoshi Morioka 2006-04-25 13:08:47 EDT
Sorry, this is already solved in upstream by amavisd-new-2.4.0.
http://www.ijs.si/software/amavisd/release-notes.txt
Comment 2 Nicolas Mailhot 2006-04-25 13:12:56 EDT
It seems thr Net::Server changed something to fix a boog amavisd-new worked
around, and as a result amavisd-new versions which include the workaround are
broken now :

http://rt.cpan.org/Public/Bug/Display.html?id=18402

Upstream advice is to switch to amavisd-new 2.4.0

-> reassigning

(Sorry I didn't notice this before releasing, all tests where green. But now
upgrading amavisd is probably the best solution)
Comment 3 Nicolas Mailhot 2006-04-25 13:16:02 EDT
Steve, what do you think ?
Comment 4 Steven Pritchard 2006-04-25 13:35:20 EDT
Upgrading amavisd-new is definitely the right choice.

I just updated devel and requested a build.  I want to do some testing with that
before pushing out an update for FC-4/FC-5.
Comment 5 Nicolas Mailhot 2006-04-25 13:46:20 EDT
btw, this can wait some time but I'd really like to remove the zoo dep (and nuke
zoo from extras) and use the sqlite backend instead of the bdb one by default

(bdb is always breaking on upgrades and the security flyby of zoo after the last
vuln was not encouraging)
Comment 6 Steven Pritchard 2006-04-25 15:36:04 EDT
It looks like the new version of amavisd-new is going to be a painless upgrade,
so I'm pushing builds for FC-4, FC-5, and devel.

In response to comment #5:
> btw, this can wait some time but I'd really like to remove the zoo dep (and nuke
> zoo from extras) and use the sqlite backend instead of the bdb one by default

Removing the zoo dep is easy.  Are you aware of any of the other hard
dependencies being risky?

Got a patch to switch to sqlite by default?  I'd be completely OK with that.
Comment 7 Nicolas Mailhot 2006-04-26 07:19:04 EDT
zoo is the worst of the lot. The others have either a cleaner/more recent
codebase or are still maintained (speaking from memory, not taking the livna
stuff into account)

As for sqlite I didn't look at it a lot, just noticed in the startup messages it
could be used as backend (and the bdb backend is breaking every month in
rawhide). I'll try to look at it some more.

Thanks for the quick update and sorry for my Net::Server messup

Note You need to log in before you can comment on or make changes to this bug.