Bug 1898928 - trellis fails to build with Python 3.10: cmake fails
Summary: trellis fails to build with Python 3.10: cmake fails
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: trellis
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gabriel Somlo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-18 10:47 UTC by Miro Hrončok
Modified: 2020-11-24 22:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-24 22:35:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-11-18 10:47:34 UTC
trellis fails to build with Python 3.10.0a2.

-- The C compiler identification is GNU 10.2.1
-- The CXX compiler identification is GNU 10.2.1
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/gcc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/g++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PythonInterp: /usr/bin/python3 (found suitable version "3.10", minimum required is "3.5") 
-- Found PythonLibs: /usr/lib64/libpython3.10.so (found suitable version "3.10.0a2", minimum required is "3.5") 
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Failed
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found Boost: /usr/include (found version "1.73.0") found components: filesystem program_options system thread chrono date_time atomic 
CMake Warning at /usr/share/cmake/Modules/FindBoost.cmake:2018 (message):
  No header defined for python-py31002; skipping header check (note:
  header-only libraries have no designated component)
Call Stack (most recent call first):
  CMakeLists.txt:68 (find_package)


CMake Warning at /usr/share/cmake/Modules/FindBoost.cmake:2018 (message):
  No header defined for python-py3100; skipping header check (note:
  header-only libraries have no designated component)
Call Stack (most recent call first):
  CMakeLists.txt:75 (find_package)


CMake Warning at /usr/share/cmake/Modules/FindBoost.cmake:2018 (message):
  No header defined for python-py310; skipping header check (note:
  header-only libraries have no designated component)
Call Stack (most recent call first):
  CMakeLists.txt:75 (find_package)


CMake Warning at /usr/share/cmake/Modules/FindBoost.cmake:2018 (message):
  No header defined for python-py3; skipping header check (note: header-only
  libraries have no designated component)
Call Stack (most recent call first):
  CMakeLists.txt:75 (find_package)


CMake Warning at /usr/share/cmake/Modules/FindBoost.cmake:2018 (message):
  No header defined for python-3.10; skipping header check (note: header-only
  libraries have no designated component)
Call Stack (most recent call first):
  CMakeLists.txt:96 (find_package)


CMake Error at CMakeLists.txt:103 (message):
  No version of Boost::Python 3.x could be found.


-- Configuring incomplete, errors occurred!
See also "/builddir/build/BUILD/prjtrellis-f93243b000c52b755c70829768d2ae6bcf7bb91a/CMakeFiles/CMakeOutput.log".
See also "/builddir/build/BUILD/prjtrellis-f93243b000c52b755c70829768d2ae6bcf7bb91a/CMakeFiles/CMakeError.log".
error: Bad exit status from /var/tmp/rpm-tmp.6W9x2s (%build)



Not sure what the problem is.


For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01769291-trellis/

For all our attempts to build trellis with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/trellis/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Gabriel Somlo 2020-11-24 21:25:08 UTC
https://github.com/YosysHQ/prjtrellis/pull/153


Note You need to log in before you can comment on or make changes to this bug.