Bug 189894 - python-reportlab requires older python
python-reportlab requires older python
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-reportlab (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 11:57 EDT by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 11:36:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2006-04-25 11:57:13 EDT
Description of problem:
python-reportlab requires older python

Version-Release number of selected component (if applicable):
python-reportlab-1.19-2
python-2.4.2-3.2.1

How reproducible:
always

Steps to Reproduce:
1. yum install python-reportlab
2.
3.
  
Actual results:
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package python-reportlab.i386 0:1.19-2 set to be updated
--> Running transaction check
--> Processing Dependency: python < 0:2.4 for package: python-reportlab
--> Finished Dependency Resolution
Error: Missing Dependency: python < 0:2.4 is needed by package python-reportlab

Expected results:
package gets installed

Additional info:
Comment 1 Brian Pepple 2006-04-25 12:09:19 EDT
Ummm, the most current python-reportlab is: python-reportlab-1.20-5.fc5. 
python-reportlab-1.19 hasn't been used since March 30, 2005:

* Wed Mar 30 2005 Brian Pepple <bdpepple@ameritech.net> - 1.20-1.fc4
- Rebuild for Python 2.4.
- Update to 1.20.
- Switch to the new python macros for python-abi
- Add dist tag.

Comment 2 Bernard Johnson 2006-04-25 12:44:27 EDT
Hmm.. I see that there is a newer python-reportlab, but yum doesn't want to
install it.  It wants the older version.

Tried a "yum clean all" but that didn't help either.



Comment 3 Brian Pepple 2006-04-25 13:30:50 EDT
I'm guessing that the problem is due to the package going from an i386 to a
noarch package.  Try uninstall python-reportlab with yum, then installing it again.
Comment 4 Bernard Johnson 2006-04-25 13:46:39 EDT
It's not currently installed.  That was the first attempt to install.
Comment 5 Brian Pepple 2006-04-25 14:06:52 EDT
Hmmmm, that's very odd.  I just did a clean installation yesterday on a machine,
and was able to install it correctly.

I don't quite understand why a FE5 repo would even have python-reportlab-1.19
rpm.  When I have some more free time, I'll try to track down the problem.
Comment 6 Bernard Johnson 2006-11-15 18:22:40 EST
I was able to successfully install it from a clean FC6 machine.

Note You need to log in before you can comment on or make changes to this bug.