Bug 1899 - networking can be installed without tcpd
Summary: networking can be installed without tcpd
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcp_wrappers (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-31 05:36 UTC by pdowler
Modified: 2008-03-06 19:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-31 15:17:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pdowler 1999-03-31 05:36:03 UTC
I just did a custom install of RedHat 5.2 and managed to
skip the tcp_wrappers package (contains /usr/sbin/tcpd).
I did install all the other networking stuff, which one
would think would require tcp_wrappers.

So, I suppose the bug is that other networking packages
should require tcp_wrappers (one shouldn't be able to not
install tcp_wrappers since almost all the networking stuff
run by inetd needs tcpd).

I only discovered it by trying to rsh to the box, failing,
and then looking in the logs to find I had no
/usr/sbin/tcpd.

Comment 1 Bill Nottingham 1999-03-31 15:17:59 UTC
this is fixed in a later release of netkit-base
(the package that contains inetd.)


Note You need to log in before you can comment on or make changes to this bug.