Bug 189911 - can't boot rawhide on an i386 box
can't boot rawhide on an i386 box
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2006-04-25 14:31 EDT by Linda Knippers
Modified: 2015-01-04 17:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 14:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci output (1.31 KB, text/plain)
2006-04-25 14:31 EDT, Linda Knippers
no flags Details

  None (edit)
Description Linda Knippers 2006-04-25 14:31:30 EDT
Description of problem:
I can't boot the rawhide i686 kernel on an HP dc7600 box.
The .2096 update kernel boots fine.  The .2127 kernel doesn't.
I don't know about what happens in between.

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2153_FC6.i686.rpm

How reproducible:
Install and boot the kernel on this paticular dc7600.  

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I've had a hard time capturing the information but it seems that the
main difference between a kernel that boots and a kernel that doesn't
is that with the kernel that doesn't boot, I get these messages:

PCI: BIOS Bug: MCFG area is not E820-reserved
PCI: Not using MMCONFIG.

instead of:

PCI: Using MMCONFIG

It hangs after these messages:

PCI: PCI BIOS revision 2.20 entry at 0xec51b, last bus=63
ACPI: Subsystem revision 20060127
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0

The messages I get when it doesn't boot seem to be in new code
introduced in patch-2.6.17-rc2.
Comment 1 Linda Knippers 2006-04-25 14:31:31 EDT
Created attachment 128212 [details]
lspci output
Comment 2 Linda Knippers 2006-04-25 14:40:30 EDT
I should have added that the code that changed is in arch/i386/pci/mmconfig.c.
I'm not sure why this is a "BIOS Bug" now where it seemed to work before 
but if there's an error path that's supposed to work, it doesn't.
Comment 3 Dave Jones 2006-04-26 02:09:31 EDT
Hmm, I turned on MSI in the rawhide kernel a little while ago, I wonder if
that's the cause.

I've enabled it in the work-in-progress errata for FC5 which you can get at
http://people.redhat.com/davej/kernels/Fedora/FC5/RPMS.kernel/
can you see if that fails in the same way?
Comment 4 Linda Knippers 2006-04-26 10:09:29 EDT
I booted the .2101_FC5 i686 kernel on my machine and it booted just fine.

The earliest kernel that I know for sure fails is the rawhide .2127 kernel
so if you have something else between .2101 and .2127 you'd like me to try,
let me know.

Thanks.
Comment 5 Dave Jones 2006-06-22 22:38:19 EDT
is this still causing problems in the 2.6.17 based kernels ?
Comment 6 Linda Knippers 2006-06-23 15:29:17 EDT
Yes, the problem is still there.  I just tested with a kernel that Steve 
Grubb builds for the LSPP project, which he just updated to 2.6.17, and
it behaves the same way.

I did try updating the firmware on this system but it didn't help.

Please let me know if there's more I can do.
Comment 7 Linda Knippers 2006-06-23 15:32:36 EDT
I should probably mention that a co-worker who has the same model system,
bought at the same time as mine, is also experiencing the problem so its
not just a single machine.  We have one example of an older version of the
same model that doesn't experience the problem.  I'm not sure what the
differnces between the older and newer ones are since they have the
same model number.
Comment 8 Tim Jackson 2006-07-23 16:44:33 EDT
This may or may not be related but I've been seeing the same symptoms on a
Toshiba Satellite A40 laptop. This laptop has worked with every kernel since FC2
but the last FC5 update it worked on was kernel-2.6.16-1.2133_FC5. All 3 (?)
subsequent updates fail to boot with the final few lines of output being as
follows: (written down and typed in so may have typos)

ACPI: PCI Interrupt Link [LNKA] (IRQs *10)
APCI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *11)
APCI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 *11)
APCI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *11)
APCI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 *11)
APCI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 *11)
APCI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 *11)
APCI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 *11)
ACPI: PCI Root Bridge [PCI0] (0000:00)
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
[...hangs here...]

Now, I tried a few kernel options to try to get to the bottom of it and here
were the results:

acpi=off makes it hang on "PCI: Probing For Hardware" instead

acpi=off pci=off makes it boot OK, but only works in text mode

pci=nomsi doesn't help at all.

pci=nobios WORKS fine, superficially. I'm entering this bug report now running
from kernel-2.6.17-1.2157_FC5.

Does this help?
Comment 9 Tim Jackson 2006-07-23 16:47:25 EDT
Further to comment #8, here's the lspci output on my Satellite A40

00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to
I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet
Controller (rev 83)
01:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus
Bridge with ZV Support (rev 33)
Comment 10 Linda Knippers 2006-08-11 13:16:23 EDT
I just tried the latest rawhide kernel (2.6.17-1.2548.fc6)
and my x86 box now boots.  It looks like there are alot more
boot messages now.  Is there anything of interest that you'd
like from my system?

I'm very happy that it boots now. :-)
Comment 11 Dave Jones 2006-08-14 14:29:09 EDT
If it boots, I guess we're done :)
Comment 12 Tim Jackson 2006-08-19 03:54:10 EDT
Yep, the latest FC5 updates kernel (2.6.17-1.2174_FC5) solves this problem for
me too.

Note You need to log in before you can comment on or make changes to this bug.