Bug 1899115 - moose fails to build with Python 3.10: ModuleNotFoundError: No module named 'parser'
Summary: moose fails to build with Python 3.10: ModuleNotFoundError: No module named '...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: moose
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968844 (view as bug list)
Depends On:
Blocks: PYTHON3.10 F35FTBFS F35FailsToInstall F36FTBFS F36FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-11-18 14:51 UTC by Tomáš Hrnčiar
Modified: 2021-08-17 08:03 UTC (History)
7 users (show)

Fixed In Version: moose-3.1.5-9.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-17 02:13:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github BhallaLab moose-core issues 437 0 None open Python 3.10 drops parser module 2021-01-06 11:51:43 UTC

Description Tomáš Hrnčiar 2020-11-18 14:51:06 UTC
moose fails to build with Python 3.10.0a2.

5:   File "/builddir/build/BUILD/moose-core-3.1.5/x86_64-redhat-linux-gnu/python/moose/utils.py", line 17, in <module>
5:     import parser
5: ModuleNotFoundError: No module named 'parser'

The parser module was remove from Python 3.10: See https://bugs.python.org/issue40939

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01772972-moose/

For all our attempts to build moose with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/moose/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ankur Sinha (FranciscoD) 2020-12-05 21:36:29 UTC
Thanks for this. Is there any information on how this is to be handled? Do we simply remove the import, or does it have to be ported to something else?

Comment 2 Ben Cotton 2021-02-09 15:25:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 3 Ben Beasley 2021-04-13 13:42:15 UTC
The use of the “parse” module is constrained to moose.utils.tweak_field(). It looks like upstream is just dropping the function: https://github.com/BhallaLab/moose-core/issues/437

Comment 4 Ankur Sinha (FranciscoD) 2021-04-13 14:25:33 UTC
Yeh, was waiting for them to make a new release, but we could carry a patch for the time being I guess. (We intend to work on Py 3.10 issues after the F34 is released)

Comment 5 Miro Hrončok 2021-06-04 20:14:34 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 6 Miro Hrončok 2021-06-07 22:59:10 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 7 Miro Hrončok 2021-06-08 11:18:01 UTC
*** Bug 1968844 has been marked as a duplicate of this bug. ***

Comment 8 Ben Cotton 2021-08-10 12:49:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 9 Orion Poplawski 2021-08-17 02:13:53 UTC
I added a patch to remove the tweak_field function and the problematic imports which appears to be what upstream is doing.

Comment 10 Ankur Sinha (FranciscoD) 2021-08-17 08:03:29 UTC
Thanks very much Orion :)


Note You need to log in before you can comment on or make changes to this bug.