Bug 189925 - RHEL4 kernel crash on reboot
RHEL4 kernel crash on reboot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity low
: rc
: ---
Assigned To: Peter Martuccelli
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 16:00 EDT by James Cornell
Modified: 2009-05-21 09:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 09:08:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Cornell 2006-04-25 16:00:42 EDT
Description of problem:

Kernel crashes on reboot on a Dell Dimension 2400.  Outputs large stack trace, then kernel panics.  
Possible ACPI bug suspected.

Version-Release number of selected component (if applicable):

2.6.9-34.EL #1

How reproducible:

Always

Steps to Reproduce:
1. Reboot
  
Actual results:

esi: c14da980   edi: 00995ff4   ebp: dd9c5000   esp: dd9c5a0
ds: 007b   es: 007b   ss: 0068
Process reboot (pid: 3743, threadinfo=dd9c5000 task=d5897220
Stack:  df6bd844 c0377f08 c024d87a dd9c5000 01234567 c0131c43 c102e6a0 00928a80
        d67ebba0 00000001 00928a80 d67ebba0 c0158a3a 00000000
        de90a4a0 df265000 df0018b0 d5897220 d67ebba0 c011a9a5 00000000

Call Trace:
  [<c024d87a>] device_shutdown+0x55/0x72
  [<c0131c43>] sys_reboot+0x16d/0x3e1
  [<c02edd88>] handle_mm_fault+0xd5/0x1fd
  [<c02b6a0b>] do_page_fault+0x1ac/0x4dc
  [<c018565c>] udp_ioctl+0x0/0x19d
  [<c0187876>] dev_ioctl+0x42/0x48c
  [<c0181ca7>] destroy_inode+0x3d/0x4c
  [<c0187876>] iput+0x5f/0x61
  [<c0181ca7>] dput+0x33/0x423
  [<c01699c6>] __fput+0xc9/0xee
  [<c016825a>] flip_close+0x59/0x5f
  [<c0311443>] syscall_call+0x7/0xb
Code: a8 0c 74 07 c6 83 a3 00 00 00 30 f6 86 f0 01 00 00 01 74 07 c6 83 a0 00 00
b6 83 83 00 00 00 0c 04 88 83 83 83 00 00
 <0)Fatal exception: panic in 5 seconds
Kernel panic - not syncing: Fatal exception

Expected results:

Clean reboot without stack trace debug or kernel panic

Additional info:
Comment 4 Brian Maly 2008-10-31 03:57:56 EDT
How is this system being rebooted? Just running the 'reboot' command?


Can someone try each of these boot args, one at a time, and see if reboot starts working properly with any of them:

reboot=w
reboot=c
reboot=b
reboot=h
Comment 5 James Cornell 2008-10-31 10:45:47 EDT
It was due to a buggy APIC controller but seems to have been fixed in 2.6.16 or so.  I do not have that machine anymore unfortunately.
Comment 7 Peter Martuccelli 2009-05-21 09:08:28 EDT
Closing out as wontfix as we do not have access to any hw exhibiting the problem.

Note You need to log in before you can comment on or make changes to this bug.