Bug 1899449 - jpype fails to build with Python 3.10: PyFrameObject {aka struct _frame} has no member named f_executing
Summary: jpype fails to build with Python 3.10: PyFrameObject {aka struct _frame} has ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jpype
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1968821 (view as bug list)
Depends On: 1890022 2005829
Blocks: F35FTBFS F35FailsToInstall F36FTBFS PYTHON3.10 F35BetaFreezeException 1969006 2049705
TreeView+ depends on / blocked
 
Reported: 2020-11-19 09:11 UTC by Tomáš Hrnčiar
Modified: 2022-02-02 18:22 UTC (History)
4 users (show)

Fixed In Version: jpype-1.3.0-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-22 00:15:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-19 09:11:24 UTC
jpype fails to build with Python 3.10.0a2.

native/common/jp_exception.cpp: In function ‘PyTracebackObject* tb_create(PyTracebackObject*, PyObject*, const char*, const char*, int)’:
native/common/jp_exception.cpp:492:9: error: ‘PyFrameObject’ {aka ‘struct _frame’} has no member named ‘f_executing’
  492 |  frame->f_executing = 0;
      |         ^~~~~~~~~~~
native/common/jp_exception.cpp:501:9: error: ‘PyFrameObject’ {aka ‘struct _frame’} has no member named ‘f_stacktop’; did you mean ‘f_stackdepth’?
  501 |  frame->f_stacktop = NULL;
      |         ^~~~~~~~~~
      |         f_stackdepth
error: command '/usr/bin/gcc' failed with exit code 1

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01772938-jpype/

For all our attempts to build jpype with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/jpype/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Raphael Groner 2020-11-22 15:45:27 UTC
Thanks for the report. Is that upstream bug related? https://bugs.python.org/issue40421

I'm going to reproduce with new version 1.1.2, see bug #1890022.

Comment 2 Raphael Groner 2021-01-27 19:13:56 UTC
This bug seems fixed with new version 1.2.1 but execution of tests fail due to a pytest error, see bug #1890022.

Comment 3 Ben Cotton 2021-02-09 15:25:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 4 Miro Hrončok 2021-06-04 20:15:51 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 5 Miro Hrončok 2021-06-07 23:00:12 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 6 Miro Hrončok 2021-06-08 11:15:38 UTC
*** Bug 1968821 has been marked as a duplicate of this bug. ***

Comment 7 Ben Cotton 2021-08-10 12:49:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 8 Miro Hrončok 2021-09-02 16:01:12 UTC
Raphael, what is the status here?

Comment 9 Miro Hrončok 2021-09-20 11:36:03 UTC
I suggest updating to 1.3.0, temporarily Exclude s390x (and a dd a comment with a link to bz2005829).

Comment 10 Fedora Update System 2021-09-20 18:46:54 UTC
FEDORA-2021-c7cc4c3cda has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-c7cc4c3cda

Comment 11 Fedora Update System 2021-09-20 20:55:11 UTC
FEDORA-2021-c7cc4c3cda has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-c7cc4c3cda`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-c7cc4c3cda

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Miro Hrončok 2021-09-21 11:35:18 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 13 Adam Williamson 2021-09-21 22:34:29 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/466 , marking accepted.

Comment 14 Fedora Update System 2021-09-22 00:15:44 UTC
FEDORA-2021-c7cc4c3cda has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.