Bug 1899474 - python-asyncssh fails to build with Python 3.10: AssertionError: ValueError not raised
Summary: python-asyncssh fails to build with Python 3.10: AssertionError: ValueError n...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-asyncssh
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Georg Sauthoff
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-19 11:01 UTC by Tomáš Hrnčiar
Modified: 2021-01-31 14:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-26 22:26:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-19 11:01:04 UTC
python-asyncssh fails to build with Python 3.10.0a2.

======================================================================
FAIL: test_expired_root (tests.test_x509._TestX509)
Test failed validation of expired X.509 root CA
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/asyncssh-2.4.2/tests/test_x509.py", line 211, in test_expired_root
    cert.validate([int_ca, root_ca], None, None, None)
AssertionError: ValueError not raised

----------------------------------------------------------------------
Ran 1198 tests in 1683.986s

FAILED (failures=1, skipped=78)
Test failed: <unittest.runner.TextTestResult run=1198 errors=0 failures=1>
/bin/sh: ssh: command not found

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01773042-python-asyncssh/

For all our attempts to build python-asyncssh with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-asyncssh/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Georg Sauthoff 2020-11-22 20:38:16 UTC
I've reported it upstream and the asyncssh author is investigating the root cause:

https://github.com/ronf/asyncssh/issues/326

Comment 2 Georg Sauthoff 2021-01-26 21:39:58 UTC
Two days ago, I pushed a new asyncssh version to rawhide that fixes the issue there.

Thus, it should now work in your Copr python 3.10 branch, as well.

I thought that a rebuild is automatically triggered in that branch, when a new package version is pushed, but this doesn't seem to have worked.

Comment 4 Georg Sauthoff 2021-01-30 14:14:11 UTC
Ok, I somehow expected that the build job would also update this issue then.

Comment 5 Miro Hrončok 2021-01-31 14:12:50 UTC
Sorry, we don't have such automation. Sometimes, we build packages with tests disabled in that copr etc., so it would need to be very careful.


Note You need to log in before you can comment on or make changes to this bug.