Bug 1899553 - python-wheel fails to build with Python 3.10: AssertionError: would build wheel with unsupported tag ('cp310', 'cp310', 'linux_x86_64')
Summary: python-wheel fails to build with Python 3.10: AssertionError: would build whe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-wheel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1891840 (view as bug list)
Depends On: 1907227
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-19 14:22 UTC by Tomáš Hrnčiar
Modified: 2021-01-04 12:26 UTC (History)
6 users (show)

Fixed In Version: python-wheel-0.36.2-1.fc34 python-wheel-0.36.2-1.eln108
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-04 12:17:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-19 14:22:13 UTC
python-wheel fails to build with Python 3.10.0a2.

Traceback (most recent call last):
  File "/builddir/build/BUILD/wheel-0.35.1/tests/testdata/extension.dist/setup.py", line 3, in <module>
    setup(name='extension.dist',
  File "/usr/lib/python3.10/site-packages/setuptools/__init__.py", line 153, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib64/python3.10/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/usr/lib64/python3.10/distutils/dist.py", line 966, in run_commands
    self.run_command(cmd)
  File "/usr/lib64/python3.10/distutils/dist.py", line 985, in run_command
    cmd_obj.run()
  File "/builddir/build/BUILDROOT/python-wheel-0.35.1-1.fc34.x86_64/usr/lib/python3.10/site-packages/wheel/bdist_wheel.py", line 328, in run
    impl_tag, abi_tag, plat_tag = self.get_tag()
  File "/builddir/build/BUILDROOT/python-wheel-0.35.1-1.fc34.x86_64/usr/lib/python3.10/site-packages/wheel/bdist_wheel.py", line 278, in get_tag
    assert tag in supported_tags, "would build wheel with unsupported tag {}".format(tag)
AssertionError: would build wheel with unsupported tag ('cp310', 'cp310', 'linux_x86_64')

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01773478-python-wheel/

For all our attempts to build python-wheel with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-wheel/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-19 14:25:36 UTC
See also bz1891840.

Comment 2 Miro Hrončok 2020-11-24 14:29:13 UTC
*** Bug 1891840 has been marked as a duplicate of this bug. ***

Comment 3 Miro Hrončok 2020-11-24 14:30:21 UTC
This is now patched in our copr: https://src.fedoraproject.org/rpms/python-wheel/pull-request/19

Final solution pending upstream decision in: https://discuss.python.org/t/5513

Comment 4 Miro Hrončok 2020-12-19 18:48:36 UTC
wheel 0.36.2 updates vendored packaging.tags to 20.8 with the fix.

Comment 5 Fedora Update System 2021-01-04 12:17:14 UTC
FEDORA-2021-a376a5e048 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2021-01-04 12:26:13 UTC
FEDORA-2021-49c57f8d00 has been pushed to the Fedora ELN stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.