Bug 189991 - pygame-devel should obsolete python-pygame-devel and pygame should obsolete python-pygame-docs as well
pygame-devel should obsolete python-pygame-devel and pygame should obsolete p...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pygame (Show other bugs)
5
All Linux
high Severity low
: ---
: ---
Assigned To: Christopher Stone
Fedora Extras Quality Assurance
: EasyFix
Depends On: 235758
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-26 10:42 EDT by Nils Philippsen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 20:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2006-04-26 10:42:57 EDT
Description of problem:

pygame obsoletes an installed python-pygame, but python-pygame-devel and
python-pygame-doc are left alone which leads to a dependency resolving error
when updating with yum --> pygame should obsolete python-pygame-doc,
pygame-devel should obsolete python-pygame-devel as well.

Version-Release number of selected component (if applicable):

old:
python-pygame-1.6.2-0.lvn.2.4
python-pygame-devel-1.6.2-0.lvn.2.4
python-pygame-doc-1.6.2-0.lvn.2.4

(supposedly) new:
pygame-devel-1.7.1-4.fc5
pygame-1.7.1-4.fc5

How reproducible:
Easy

Steps to Reproduce:
1. Have the old packages installed
2. yum update

Actual results:
"""
Error: Missing Dependency: python-pygame = 0:1.6.2-0.lvn.2.4 is needed by
package python-pygame-devel
"""

Expected results:
no error, all old packages replaced by new pygame, pygame-devel

Additional info:
Comment 1 Christopher Stone 2006-04-26 11:37:26 EDT
Fixed and rebuilt.  Thanks.
Comment 2 Nils Philippsen 2006-05-03 11:30:23 EDT
Updating left python-pygame-doc-1.6.2-0.lvn.2.4 on the system, probably
"python-pygame-doc < %{?epoch:%{epoch}:}%{version}-%{release}" should be
obsoleted by pygame-devel (as it contains the example files now).
Comment 3 Christopher Stone 2006-05-03 12:23:22 EDT
ugh, I obsoleted python-pygame-docs, not python-pygame-doc.  Fixed in next build.
Comment 4 Nicolas Chauvet (kwizart) 2007-04-20 14:56:05 EDT
pygame-devel is no more accessible on rawhide (because headers were merged into
the main package). 

This would be nice to have a least a virtual Provides: pygame-devel
This is needed to build python-kaa-imlib2 on devel (FC-6 built fine already...)

Comment 5 Christopher Stone 2007-04-20 21:14:44 EDT
Yes I know, I have been planning on doing this for months now, but fortunately
another such multilib issue came up which brings this change into question.  I
made the original change out of frustration because of some bizzare multilib
problem.

If you check the cvs logs, the removing of the pygame-devel package was
suggested by Michael Schwendt.  After taking a second look it seems he is saying
that his original suggestion was incorrect.  So as far as I understand it, the
change needs to be reverted back in pygame for devel, and then pygame needs to
be added to some kind of multilib blacklist.

So once pygame is on the blacklist, then I can revert the devel change so we are
basically back to how the package looks in FC-6.

I think f13 in #fedora-devel can help out here. /msg me (XulChris) next time you
are on IRC.
Comment 6 Christopher Stone 2007-04-23 20:16:48 EDT
pygame has been blacklisted.
http://cvs.fedora.redhat.com/bonsai/cvsblame.cgi?file=extras-buildsys/utils/pushscript/Config_Extras.py&rev=&root=/cvs/fedora

reverted back to fc6 version.

verified fixed.

Note You need to log in before you can comment on or make changes to this bug.