Bug 1900057 - EPEL7 - lcgdm-dav won't install on RHEL 7
Summary: EPEL7 - lcgdm-dav won't install on RHEL 7
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: lcgdm-dav
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ricardo Rocha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: EPEL7FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-11-20 17:23 UTC by Troy Dawson
Modified: 2020-11-30 15:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-30 15:24:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Troy Dawson 2020-11-20 17:23:41 UTC
lcgdm-dav-server and mod_lcgdm_dav (subpackages of lcgdm-dav) won't install on RHEL or CentOS 7

They fail with

ERROR: lcgdm-dav-server.x86_64

 Problem: package lcgdm-dav-server-0.22.0-1.el7.x86_64 requires dmlite-libs(x86-64) >= 1.11.0, but none of the providers can be installed
  - package dmlite-libs-1.14.2-1.el7.x86_64 conflicts with lcgdm-dav-server < 1.14.2 provided by lcgdm-dav-server-0.22.0-1.el7.x86_64
  - conflicting requests

ERROR: mod_lcgdm_dav.x86_64

 Problem: package mod_lcgdm_dav-0.22.0-1.el7.x86_64 requires libdmlite.so.0()(64bit), but none of the providers can be installed
  - package dmlite-libs-1.14.2-1.el7.x86_64 conflicts with mod_lcgdm_dav < 1.14.2 provided by mod_lcgdm_dav-0.22.0-1.el7.x86_64
  - conflicting requests


It looks like dmlite was updated on EPEL7.  In Fedora lcgdm-dav was retired with the note "Obsoleted by dmlite-apache-httpd"

Please retire lcgdm-dav from EPEL7, or fix things so it can be installed.
If you have not responded in a week, we will have a proven packager retire the package.
If you know you will not be able to get to it and would like it fixed sooner, please let us know in this bug.

Comment 1 oliver.keeble 2020-11-23 07:41:25 UTC
Package retired from EPEL-7.

Comment 2 Troy Dawson 2020-11-30 15:24:46 UTC
I have verified that the package is no longer in the EPEL7 repositories.
Thank You


Note You need to log in before you can comment on or make changes to this bug.