Bug 190006 - mount -t cifs does not work with Win98 shares -t smbfs not supported
mount -t cifs does not work with Win98 shares -t smbfs not supported
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2006-04-26 12:39 EDT by Lloyd Kvam
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-20 11:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lloyd Kvam 2006-04-26 12:39:35 EDT
Description of problem:
Unable to mount win98 shares

Version-Release number of selected component (if applicable):

How reproducible:
Requires a Win98 system offering a share.

Steps to Reproduce:
1. mount -t cifs //win98pc/share /winmount/winshare
mount error 112 = Host is down

2. mount -t smbfs //win98pc/share /winmount/winshare
mount: unknown filesystem type 'smbfs'

Actual results:
mount error 112 = Host is down

Expected results:
quiet mount of the share

Additional info: some discussion, but I could not find bug report

Comment 1 Ray 2006-08-15 15:39:17 EDT
I'm having the same problem trying to mount a samba share from my Zaurus.

It seems to me that cifs is not ready to be a *replacement* for smbfs.

Please bring smbfs back ASAP so that Zauriis and old Windoze boxes are not left 
out in the cold!
Comment 2 Lacrocivious Acrophosist 2006-08-21 13:06:09 EDT
I have had the same mount problem for many, many months, and continue to run two
systems with FC4 solely due to this issue. I have wasted literally tens of hours
researching this, to no applicable result as I am not a programmer. The best
information I could find is that smbfs 'is not supported' because 'there is no
maintainer' for it. I have no idea whether this meant 'no maintainer' for FC
alone, or more broadly.

In my humble and ignorant opinion it was a large mistake to remove smbfs support
while 'replacing' it with a demonstrably unready cifs.

In any event, there are more Win9x shares out there in the small business
community than anyone at Fedora probably realizes, and this continues to be a
major stumbling block for my own small business, attempting to migrate other
small businesses to Linux. They need those shares at least for a time during
transition, not to mention for their myriad creaky vertical market apps.

Forget about custom kernel compiles... even if I did that for myself, there is
no way I could expect my clients to do it.

I am glad to see this issue raised again, and hopefully this time someone with
the necessary skills might be persuaded to construct a fix for us ;-)

Comment 3 Steve French 2006-11-25 15:57:31 EST
cifs can mount to windows 98 but there are a couple of differences with it and
smbfs.  cifs does not assume that the tcp name and the netbios name of the server
are the same (it makes you specify the netbios name on the mount) and cifs does
not let you mount with weak password hashes by default (without passing a mount
option, or setting the security flags).

(Assuming RedHat still builds with the required build options
("CONFIG_CIFS_WEAK_PW_HASH") required for the older less secure servers, and
that the user mounts with option "sec=lanman" (to specify that the user wants to
use weaker lanman security which is all windows 98 supports) and "servern=" (to
specify the netbiosname of the target server).

There are a few improvements with time handling that have been made recently
(2.6.19-rc) that are not in FC, but not many.
Comment 4 Lloyd Kvam 2007-04-18 16:51:58 EDT
(In reply to comment #3)
Thanks for the information.  I was still unable to mount the Win98 share.  
mount -t cifs //win98pc/c /winmount/winshare -o sec=lanman,servern=win98pc
gave the same host down error response.  I tried variations with the IP address
and sec=none.

However, smbclient had no difficulties "smbclient //win98pc/c" with an empty
password simply worked.  Then I discovered that nautilus will access the share
as smb://win98pc in the location bar.  These methods are good enough for my needs.
Comment 5 Jeff Layton 2007-09-19 16:31:26 EDT
This should be working now in recent Fedora versions
Comment 6 Lloyd Kvam 2007-09-20 09:08:58 EDT
(In reply to comment #5)
> This should be working now in recent Fedora versions

Using fedora 7 (and 6), this command worked for me

mount -t cifs //WIN98PC/C winshare/ -o guest,servern=WIN98PC

Note that I had to enter *ALL* of the win98 references using upper case
characters even though the actual text entries on the win98 computer were lower
case.  The earlier recommendation of sec=lanman was not necessary for me.  The
mount still succeeded when I included it.  

mount -t cifs //WIN98PC/C winshare/ -o guest,sec=lanman,servern=WIN98PC

Perhaps this has been working all along so long as servern was specified *AND*
the win98 references were mapped to upper case.

Thanks for the assistance.
Comment 7 Lloyd Kvam 2007-09-24 14:43:18 EDT
here is some text
and a little bit more

Note You need to log in before you can comment on or make changes to this bug.