Bug 1900066 - EPEL7 - python2-jenkins-job-builder won't install on RHEL 7.9
Summary: EPEL7 - python2-jenkins-job-builder won't install on RHEL 7.9
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-jenkins-job-builder
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ken Dreyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1811778 (view as bug list)
Depends On:
Blocks: EPEL7FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-11-20 17:44 UTC by Troy Dawson
Modified: 2021-02-09 07:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-04 22:21:32 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Troy Dawson 2020-11-20 17:44:20 UTC
Current python2-jenkins-job-builder (a subpackage of python-jenkins-job-builder) for EPEL7 fails to install with:

ERROR: python2-jenkins-job-builder.noarch

 Problem: conflicting requests
  - nothing provides python-jenkins needed by python2-jenkins-job-builder-1.4.0-3.el7.noarch

It looks like it the spec needs to be updated to say python2-jenkins instead of python-jenkins

Please fix this package so that it can be installed in RHEL 7.9.
If you have not responded in a week, we will have a proven packager fix it.
If you know you will not be able to get to it and would like it fixed sooner, please let us know in this bug.
If you feel this package should no longer be in EPEL7, please let us know in this bug.

Comment 1 Ken Dreyer (Red Hat) 2021-02-04 17:14:17 UTC
Probably a duplicate of bz 1811778

Comment 2 Ken Dreyer (Red Hat) 2021-02-04 17:14:47 UTC
All my hosts are running CentOS 8 or RHEL 8, so I am not paying much attention to EPEL 7 at this point.

Comment 3 Troy Dawson 2021-02-04 22:21:32 UTC
Actually, this was fixed by the python-jenkins maintainer.  They put a provides in python2-jenkins.
This was to fix a different package, with the same error, so I closed that bug, but missed this one.
So, in short, it's all good now.

Comment 4 Pavel Holica 2021-02-09 07:30:07 UTC
*** Bug 1811778 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.