Bug 1900187 - mutter 3.38.1-2 breaks Steam games: Civilization 5, Portal, Portal 2, Black Mesa
Summary: mutter 3.38.1-2 breaks Steam games: Civilization 5, Portal, Portal 2, Black Mesa
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1900406 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-21 09:07 UTC by Felix Schwarz
Modified: 2020-11-24 02:51 UTC (History)
8 users (show)

Fixed In Version: mutter-3.38.1-3.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-24 02:51:05 UTC
Type: Bug


Attachments (Terms of Use)
screenshot #1 (584.36 KB, image/png)
2020-11-21 10:01 UTC, Felix Schwarz
no flags Details
screenshot #2 (370.70 KB, image/png)
2020-11-21 10:04 UTC, Felix Schwarz
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME mutter issues 1534 0 None None None 2020-11-21 16:41:01 UTC

Description Felix Schwarz 2020-11-21 09:07:33 UTC
The recent update (mutter 3.38.1-2, https://bodhi.fedoraproject.org/updates/FEDORA-2020-543204d787) broke Civilization 5 for me (running from Flatpak Steam). The game does not start fullscreen anymore. Instead I only see a window and rendering is off (seems like the game assumes the window is much bigger, parts of the rendered graphics is cut off at the top/right). No controls inside the game are clickable so the game does not work at all anymore.

Downgrading to mutter 3.38.1-1 makes the game playable again.

Comment 1 Michal Schmidt 2020-11-21 09:38:14 UTC
Portal, Portal 2, Black Mesa are similarly affected for me.
I confirm downgrading to mutter-3.38.1-1.fc33.x86_64 helps.

Comment 2 Felix Schwarz 2020-11-21 10:01:40 UTC
Created attachment 1731631 [details]
screenshot #1

Comment 3 Felix Schwarz 2020-11-21 10:04:31 UTC
Created attachment 1731632 [details]
screenshot #2

I added two screenshots where the problem is clearly visible. With the previous version of mutter the game starts in fullscreen mode immediately. After the update it looks like shown on the screenshots and it seems the clickable zones are off as the game does not react on clicks on visible buttons.

It does not matter if I run gnome-shell with X.org or Wayland.

Comment 4 Jonas Ådahl 2020-11-21 16:41:02 UTC
This should be fixed in coming 3.38.2, see linked gitlab issue.

Comment 5 Felix Schwarz 2020-11-22 12:27:31 UTC
Jonas: Any idea when 3.38.2 is to be expected? If this is more than maybe a few days I think mutter should get either additional patches or should revert the extra patches. After all this is a highly visible regression in a stable version of Fedora where the culprit is clearly identified.

Comment 6 Martin Wolf 2020-11-22 23:54:21 UTC
*** Bug 1900406 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2020-11-23 08:39:22 UTC
FEDORA-2020-c8e6be142d has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c8e6be142d

Comment 8 Felix Schwarz 2020-11-23 09:40:02 UTC
Thank you very much for fixing this so quickly :-)

Comment 9 Fedora Update System 2020-11-24 02:51:05 UTC
FEDORA-2020-c8e6be142d has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.