Bug 1900546
| Summary: | [CBT][incremental backup] Engine reports that backup was finalized when stopping backup failed | ||||||||||||
|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Nir Soffer <nsoffer> | ||||||||||
| Component: | BLL.Storage | Assignee: | Eyal Shenitzky <eshenitz> | ||||||||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Ilan Zuckerman <izuckerm> | ||||||||||
| Severity: | high | Docs Contact: | |||||||||||
| Priority: | unspecified | ||||||||||||
| Version: | 4.4.4.1 | CC: | bugs, eshenitz, sfishbai | ||||||||||
| Target Milestone: | ovirt-4.4.4 | ||||||||||||
| Target Release: | 4.4.4.4 | ||||||||||||
| Hardware: | Unspecified | ||||||||||||
| OS: | Unspecified | ||||||||||||
| Whiteboard: | |||||||||||||
| Fixed In Version: | ovirt-engine-4.4.4.4 | Doc Type: | No Doc Update | ||||||||||
| Doc Text: | Story Points: | --- | |||||||||||
| Clone Of: | Environment: | ||||||||||||
| Last Closed: | 2020-12-21 12:35:53 UTC | Type: | Bug | ||||||||||
| Regression: | --- | Mount Type: | --- | ||||||||||
| Documentation: | --- | CRM: | |||||||||||
| Verified Versions: | Category: | --- | |||||||||||
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |||||||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||||||
| Embargoed: | |||||||||||||
| Attachments: |
|
||||||||||||
|
Description
Nir Soffer
2020-11-23 11:00:09 UTC
According to the logs, the engine failed to finalize the backup as expected. 2020-11-22 17:55:00,030+02 INFO [org.ovirt.engine.core.bll.StopVmBackupCommand] (default task-5) [a8f31e56-1a74-418c-9131-ee708e368f06] Failed to stop VmBackup 'b7de98d7-914c-4c24-a9dd-a3202505e511' The problem here is that the audit log reports that the backup was finalized instead of failed to finalize. 2020-11-22 17:55:00,042+02 INFO [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-5) [a8f31e56-1a74-418c-9131-ee708e368f06] EVENT_ID: VM_BACKUP_FINALIZED(10,794), Backup <UNKNOWN> for VM backup-raw finalized (User: admin@internal-authz). The fix will be to propagate the VM_BACKUP_FAILED_TO_FINALIZE audit log instead of the VM_BACKUP_FINALIZED. Created attachment 1739343 [details]
failed attempt to verify - dumpxml
Created attachment 1739662 [details]
engine + vdsm + dumpxml for the second attempt to verify
Verified on:
ovirt-engine-4.4.4.4-0.9.el8ev.noarch
rhv-release-4.4.4-5-001.noarch
0. Edit the /usr/lib/python3.6/site-packages/vdsm/virt/backup.py to raise the exception
1. Create a VM with a disk that enabled for incremental backup.
2. Start the VM.
3. Start a backup for the VM
[root@storage-ge5-vdsm3 examples]# python3 backup_vm.py -c engine start 89502d53-710a-4cd2-85ab-35a934f5f306
[ 0.0 ] Starting full backup for VM '89502d53-710a-4cd2-85ab-35a934f5f306'
[ 1.9 ] Waiting until backup 21c37d1d-1cb8-4aef-80f9-2ca0c7ca4c5b is ready
[ 2.9 ] Created checkpoint '7d2debbb-c320-475e-96bc-676dfb390f86' (to use in --from-checkpoint-uuid for the next incremental backup)
[ 3.0 ] Backup 21c37d1d-1cb8-4aef-80f9-2ca0c7ca4c5b is ready
5. Stop the VM backup
[root@storage-ge5-vdsm3 examples]# python3 backup_vm.py -c engine stop 89502d53-710a-4cd2-85ab-35a934f5f306 21c37d1d-1cb8-4aef-80f9-2ca0c7ca4c5b
[ 0.0 ] Finalizing backup 21c37d1d-1cb8-4aef-80f9-2ca0c7ca4c5b
Traceback (most recent call last):
File "backup_vm.py", line 429, in <module>
main()
File "backup_vm.py", line 161, in main
args.command(args)
File "backup_vm.py", line 245, in cmd_stop
stop_backup(connection, args.backup_uuid, args)
File "backup_vm.py", line 327, in stop_backup
backup_service.finalize()
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/services.py", line 33306, in finalize
return self._internal_action(action, 'finalize', None, headers, query, wait)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 299, in _internal_action
return future.wait() if wait else future
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 55, in wait
return self._code(response)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 296, in callback
self._check_fault(response)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 132, in _check_fault
self._raise_error(response, body)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 118, in _raise_error
raise error
ovirtsdk4.Error: Fault reason is "Operation Failed". Fault detail is "[]". HTTP response code is 400.
Expected results -
Stop backup should fail and audit logs should include the following message - VM_BACKUP_FAILED_TO_FINALIZE
Actual result:
Stop backup should fail
engine log include message VM_BACKUP_FAILED_TO_FINALIZE
2020-12-17 11:09:45,184+02 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-11) [feb0506c-9156-42a6-ba16-d9214d63b39d] EVENT_ID: VM_BACKUP_FAILED_TO_FINALIZE(10,795), Backup <UNKNOWN> for VM test failed to finalize (User: admin@internal-authz).
Attaching engine + vdsm logs
Created attachment 1739931 [details]
verification logs engine + vdsm
This bugzilla is included in oVirt 4.4.4 release, published on December 21st 2020. Since the problem described in this bug report should be resolved in oVirt 4.4.4 release, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |