Bug 1900643 - lector: FTBFS in Fedora rawhide
Summary: lector: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lector
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Audrey Yeena Toskin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-23 13:22 UTC by Tomáš Hrnčiar
Modified: 2020-12-17 03:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-17 03:37:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-23 13:22:48 UTC
Description of problem:
Package lector fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.5.1-2.fc33

Steps to Reproduce:
koji build --scratch f34 lector-0.5.1-2.fc33.src.rpm
https://koji.fedoraproject.org/koji/taskinfo?taskID=56121251

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/lector

Comment 1 Tomáš Hrnčiar 2020-11-23 13:36:54 UTC
Installing lector script to /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64/usr/bin
writing list of installed files to 'install.txt'
+ rm -rfv /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64/usr/bin/__pycache__
+ mkdir -p /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/metainfo/
+ cp --archive /builddir/build/SOURCES/io.github.BasioMeusPuga.Lector.metainfo.xml /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/metainfo/
+ mv /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/applications/lector.desktop /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/applications/io.github.BasioMeusPuga.Lector.desktop
+ mv /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/icons/hicolor/scalable/apps/Lector.png /builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/icons/hicolor/512x512/apps/Lector.png
mv: cannot move '/builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/icons/hicolor/scalable/apps/Lector.png' to '/builddir/build/BUILDROOT/lector-0.5.1-2.fc34.x86_64//usr/share/icons/hicolor/512x512/apps/Lector.png': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.AnfOnv (%install)

Comment 2 Audrey Yeena Toskin 2020-12-01 23:28:24 UTC
Oh, sorry, I immediately assumed this was related to the dependency python3-djvulibre failing to build in Bug #1897558... Upon actually reading the error output, turns out the target directory %{buildroot}/%{_datadir}/icons/hicolor/512x512/apps/ was missing when installing the Lector icon.

After fixing that, looks like Lector builds without issue now.

  https://koji.fedoraproject.org/koji/taskinfo?taskID=56558711

  https://bodhi.fedoraproject.org/updates/FEDORA-2020-ed63d1f218


Note You need to log in before you can comment on or make changes to this bug.