Bug 190075 - wpa_supplicant + WEP + madwifi + NetworkManager
wpa_supplicant + WEP + madwifi + NetworkManager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 07:23 EDT by Giuseppe Castagna
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 12:23:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Giuseppe Castagna 2006-04-27 07:23:24 EDT
Description of problem:

NetworkManager with WEP and madwifi does not work beacause of a bug of
wpa_supplicant. This has been recently fixed in wpa_supplicant 0.4.9. See

http://hostap.epitest.fi/bugz/show_bug.cgi?id=140

Could you please upgrade to the new version? Thanks
Comment 1 Matthias Saou 2006-04-28 06:34:21 EDT
I ran into the same problem. Apparently Dan fixed it in Rawhide today :

wpa_supplicant-1:0.4.8-10.fc6
-----------------------------
* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
- Fix up madwifi-ng private ioctl()s for r1331 and later
- Update madwifi headers to r1475
Comment 2 Giuseppe Castagna 2006-04-28 20:25:54 EDT
Indeed it was fixed. I got the rawhide source and compile it on my (pretty
standard) fc5 installation: now Madwify svn revision 1531 with WEP and
NetworkManager work like a charme (it just took me some time to understand that
I had to start /etc/init.d/dhcdbd)

My opinion is that you could push it to fc5-update-testing.
Comment 3 Marian-Nicolae ION 2006-05-01 06:40:35 EDT
does it really needs dhcdbd ? I don't have it but it works OK... the only 
thing I did was to start wpa_supplicant *before* network..
Comment 4 Giuseppe Castagna 2006-05-01 07:27:31 EDT
Well, I do not know really. I just noticed that after having updated
wpa_supplicant connection failed, but with a different message, that is


Apr 29 02:03:58 mirto NetworkManager: <WARNING>  nm_dhcp_manager_get_state_for_d
evice (): dhcdbd not running!
Apr 29 02:04:11 mirto NetworkManager: <WARNING>  nm_dhcp_manager_begin_transacti
on (): dhcdbd not running!

So I started dhcdbd and then it started to work. Is it me who have a weird
configuration?

Comment 5 Thomas M Steenholdt 2006-05-15 08:21:41 EDT
FWIW (and i've only tested with one accessoint so far) - Using madwifi svn
version 1552 (today), wpa_supplicant-0.4.8-10.fc5 and NetworkManager-0.6.2-2.fc5
things appear to be working nicely.

I've tried unencrypted, WEP- and WPA encrypted against a 3Com 3CRWE454G72
accesspoint. Everything worked like a charm!

Note You need to log in before you can comment on or make changes to this bug.