Bug 1900816 - swid-tools fails to build: dnf transaction failed
Summary: swid-tools fails to build: dnf transaction failed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: swid-tools
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-23 19:00 UTC by Miro Hrončok
Modified: 2021-02-01 16:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-01 16:26:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-11-23 19:00:42 UTC
swid-tools fails to build with Python 3.10.0a2.

RPM transaction start.
  Preparing        :                                                        1/1 
Installed: pkgdep-1.0.0-1.fc28.noarch
  Installing       : pkgdep-1.0.0-1.fc28.noarch                             1/2Error unpacking rpm package pkgdep-1.0.0-1.fc28.noarch
 
Installed: pkg1-1.2.0-1.fc28.x86_64
  Installing       : pkg1-1.2.0-1.fc28.x86_64                               2/2 
error: unpacking of archive failed: cpio: mkdir failed - No such file or directory
error: pkgdep-1.0.0-1.fc28.noarch: install failed

Error unpacking rpm package pkg1-1.2.0-1.fc28.x86_64
RPM transaction over.
Errors occurred during transaction.
  Verifying        : pkg1-1.2.0-1.fc28.x86_64                               1/2 
  Verifying        : pkgdep-1.0.0-1.fc28.noarch                             2/2 
timer: verify transaction: 43 ms
timer: transaction: 218 ms
No installed rpm found for package pkg1-1.2.0-1.fc28.x86_64, will not sync SWID tag.
No installed rpm found for package pkgdep-1.0.0-1.fc28.noarch, will not sync SWID tag.

Failed:
  pkg1-1.2.0-1.fc28.x86_64              pkgdep-1.0.0-1.fc28.noarch             

Cleaning up.

Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/dnf/cli/main.py", line 67, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.10/site-packages/dnf/cli/main.py", line 106, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.10/site-packages/dnf/cli/main.py", line 130, in cli_run
    ret = resolving(cli, base)
  File "/usr/lib/python3.10/site-packages/dnf/cli/main.py", line 176, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.10/site-packages/dnf/cli/cli.py", line 258, in do_transaction
    raise dnf.exceptions.Error(_('Transaction failed'))
dnf.exceptions.Error: Transaction failed
Error: Transaction failed

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01776378-swid-tools/

For all our attempts to build swid-tools with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/swid-tools/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-23 19:56:39 UTC
It also fails in rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=56145060

Comment 2 Jan Pazdziora 2020-11-24 11:43:50 UTC
The problem seems to be caused by fakechroot used in the tests but debugging fakechroot is hard on rawhide because it FTBFS as well: bug 1901049.

Comment 3 Jan Pazdziora 2021-01-30 13:06:18 UTC
I've disabled the dnf plugin tests that require fakechroot in swid-tools-0.8.11-3.fc34, on its way to rawhide via https://bodhi.fedoraproject.org/updates/FEDORA-2021-bbec160f46.

Comment 4 Jan Pazdziora 2021-02-01 16:26:14 UTC
The build is now in Fedora rawhide.


Note You need to log in before you can comment on or make changes to this bug.