Bug 190092 - regression: -I option does not work
regression: -I option does not work
Status: CLOSED DUPLICATE of bug 176587
Product: Fedora
Classification: Fedora
Component: traceroute (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-04-27 10:33 EDT by James Morris
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-28 02:06:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Morris 2006-04-27 10:33:52 EDT
Description of problem:

The traceroute currently in FC5 has regressed and does not have an -I option
allowing ICMP packets to be sent instead of UDP.

This is important in circumstances where UDP and packets are filtered and/or
handled differently.  It also breaks all existing scripts and applications using -I.

Version-Release number of selected component (if applicable):


How reproducible:

Run traceroute with -I option.

Steps to Reproduce:
1. traceroute -I somewhere
Actual results:

traceroute: invalid option -- I
usage: traceroute [-nFV] [-f first_ttl] [-m max_hops] [-p port]
           [-s source_addr] [-i interface] [-g gateway]
           [-t tos] [-w timeout] [-q nqueries] host [packetlen]

Expected results:

For it to work.

Additional info:
Comment 1 Radek Vokal 2006-04-28 02:06:11 EDT

*** This bug has been marked as a duplicate of 176587 ***

Note You need to log in before you can comment on or make changes to this bug.