Bug 190103 - ftp leaks socket fds when it fails to open a file
ftp leaks socket fds when it fails to open a file
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: krb5 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks: 189875
  Show dependency treegraph
 
Reported: 2006-04-27 12:29 EDT by David Kovalsky
Modified: 2014-03-31 19:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 12:01:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2006-04-27 12:29:12 EDT
Description of problem:
After an attempt to download a file that does not exist a socket does not get
closed.

Version-Release number of selected component (if applicable):
krb5-workstation-1.3.4-27

How reproducible:
always

Steps to Reproduce:
1. Connect to an ftp site using ftp
2. Count the number of opened sockets using lsof
($ lsof| grep ftp| grep -v httpd| grep -v vsftpd | wc -l)
3. Try to "get" an inexistant file a good number of times
4. See the number of file descriptors increase compared to 2.

  
Actual results:
number of sockets increaces

Expected results:
number of sockets does not increase

Additional info:
same problem as bug #174599
Comment 1 David Kovalsky 2006-04-27 12:33:13 EDT
Ooops, actually the version on RHEL3 is krb5-workstation-1.2.7-52
Comment 2 Nalin Dahyabhai 2006-04-28 17:06:36 EDT
Adding devel ACK.  Obviously a bug, has potential to break the FTP client, looks
like we've got a reproducer.
Comment 6 Suzanne Yeghiayan 2007-05-08 11:57:03 EDT
Unfortunately this issue was not resolved in RHEL 3.9 and it is now too late as
we are past Beta Freeze.

Since RHEL 3.9 is the last release for RHEL 3, if you still want this issue
fixed, please work with Red Hat Support and request an async errata.
Comment 7 RHEL Product and Program Management 2007-05-08 12:01:17 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.