Bug 190127 - Xdm's configuration files are not marked %config
Xdm's configuration files are not marked %config
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xdm (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 16:08 EDT by Göran Uddeborg
Modified: 2014-06-18 05:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.1.6-9.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 08:34:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.34 KB, patch)
2009-06-09 12:45 EDT, Matěj Cepl
no flags Details | Diff

  None (edit)
Description Göran Uddeborg 2006-04-27 16:08:29 EDT
Description of problem:
The files in /etc/X11/xdm, as well as /etc/pam.d/xdm are things to be
configurerd by the sysadm.  But they seem not to be marked as config files in
the RPM, so any changes would be gone by the next upgrade.

Version-Release number of selected component (if applicable):
xorg-x11-xdm-1.0.1-1.2

How reproducible:
Every time

Steps to Reproduce:
1.rpm -qc xorg-x11-xdm

Actual results:
Nothing.

Expected results:
/etc/X11/xdm/GiveConsole
/etc/X11/xdm/TakeConsole
/etc/X11/xdm/Xaccess
/etc/X11/xdm/Xreset
/etc/X11/xdm/Xresources
/etc/X11/xdm/Xservers
/etc/X11/xdm/Xsession
/etc/X11/xdm/Xsetup_0
/etc/X11/xdm/Xstartup
/etc/X11/xdm/Xwilling
/etc/X11/xdm/xdm-config
/etc/pam.d/xdm
/etc/pam.d/xserver
Comment 1 Mike A. Harris 2006-06-06 05:22:33 EDT
I'll review these to see if we should consider flagging any of the config
files as such.  The script files are not intended to be treated as config
files however.
Comment 2 Göran Uddeborg 2006-06-07 16:35:53 EDT
They aren't?  I thought they were.  Editing Xsession has been how I tuned the
default session, for example.  Am I supposed to write a whole new script and
point to it from xdm-config, instead?
Comment 3 Mike A. Harris 2006-07-17 18:05:16 EDT
(In reply to comment #2)
> They aren't?  I thought they were.  Editing Xsession has been how I tuned the
> default session, for example.  Am I supposed to write a whole new script and
> point to it from xdm-config, instead?

The script files are OS supplied scripts which we sometimes need to update
for security purposes, or for new OS features.  Since it is possible that
avoiding updating to the new script due to the file having been edited
by the user, may cause the system to be inoperable, we need to ensure that
after every rpm package install, the Red Hat supplied scripts are what
is currently used after upgrades.

Admins do sometimes hand edit these files however, even though they are
not technically config files.  I'm going to review each individual file
in the xdm and xinit packages and try to determine a better way of flagging
the files than what it is currently.  I notice the pam.d files are missing
their flags/attrs, and will fix that for now.

I think we might be able to find a compromise for some of these things.
Comment 4 Göran Uddeborg 2006-07-18 14:50:12 EDT
I see.

For your reference, these are the files I actually have modified on the system
which triggered me to create this bugzilla:

/etc/X11/xdm/Xreset
/etc/X11/xdm/Xresources
/etc/X11/xdm/Xservers
/etc/X11/xdm/Xsession
/etc/X11/xdm/Xsetup_0
/etc/X11/xdm/Xstartup
/etc/X11/xdm/xdm-config
/etc/pam.d/xdm
Comment 5 Søren Sandmann Pedersen 2007-03-23 12:45:40 EDT
Putting on F7 target - we should either fix it, or close this bug.
Comment 6 Matěj Cepl 2007-07-03 09:51:11 EDT
Fedora Core 5 is no longer supported, please, could you reproduce this bug with
the updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX/INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 7 Göran Uddeborg 2007-07-03 15:48:52 EDT
The Fedora 7 has the pam files and app-defaults/Chooser marked as config files.
 But even taking comment 3 into account, I would argue there are more files that
should be marked.  Files like xdm-config (It's even CALLED "config"!:-),
Xresources and Xservers for example.
Comment 8 Matěj Cepl 2008-05-13 06:23:18 EDT
Still not fixed in F9:

[root@hubmaier ~]# rpm -qc xorg-x11-xdm
/etc/pam.d/xdm
/etc/pam.d/xserver
/usr/share/X11/app-defaults/Chooser
[root@hubmaier ~]# 
Comment 9 Bug Zapper 2008-05-13 22:09:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Chris Tyler 2009-05-13 19:48:35 EDT
This bug is still present -- I lost a multiseat Xservers configuration a few days ago due to an update.
Comment 11 Jan "Yenya" Kasprzak 2009-06-08 04:58:40 EDT
Today after installing the xdm update xorg-x11-xdm-1.1.6-8.fc10.x86_64 on my F10 dual-seat desktop I have found that it silently replaced my Xservers file with a single-seat config. I have decided to report this trivial bug to bugzilla, and was very surprised when I found this bug report.

I can't believe this 3+ years old trivial bug is still not fixed. Someone, _please_ add the %config directive to the spec file to the files listed in comment #4.

Also (Matěj?), please bump the Version tag of this bug to 11, as the bug is also present in xorg-x11-xdm-1.1.6-7.fc11.x86_64.rpm.
Comment 12 Matěj Cepl 2009-06-09 12:45:31 EDT
Created attachment 347055 [details]
proposed patch
Comment 13 Matěj Cepl 2009-06-09 12:47:57 EDT
a) I am sorry for missing this bug for so long,
b) could you please comment on the proposed patch in attachment 347055 [details], please? I have kind of hard time to distinguish which are example scriptlets which could (and should) be changed according to the local needs, and which are real scripts which needs to be maintained by us.
Comment 14 Chris Tyler 2009-06-09 12:59:35 EDT
The patch would do it for me.
Comment 15 Göran Uddeborg 2009-06-09 13:48:23 EDT
The patch in comment 12 would certainly be an improvement.  In addition, I would also like to see the following files marked as %config.

/etc/X11/xdm/Xaccess
/etc/X11/xdm/Xstartup
/etc/X11/xdm/Xwilling
/etc/X11/xdm/xdm-config

In particular xdm-config and Xaccess seems like an obvious config files.  But the other two are also things I would like to tune.  (And have tuned.)
Comment 16 Noura El hawary 2009-06-09 17:48:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Jan "Yenya" Kasprzak 2009-06-10 05:02:49 EDT
I agree with comment #15.

Speaking of myself, I modified Xservers, Xaccess, Xwilling and xdm-config files in the past.
Comment 18 Fedora Update System 2009-06-10 16:51:35 EDT
xorg-x11-xdm-1.1.6-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-xdm-1.1.6-9.fc11
Comment 19 Matěj Cepl 2009-06-10 16:55:52 EDT
And BTW, Yenya, concerning your blog on http://www.fi.muni.cz/~kas/blog/index.cgi/computers/desktops/is-ekiga-doomed.writeback. I got pretty violently attacked for fixing xdm, and when I argumented with gdm not able to do automatic login and XDMCP I was pointed to the documentation where you find things like http://library.gnome.org/admin/gdm/2.26/configuration.html.en#xdmcpsection.
Comment 20 Jan "Yenya" Kasprzak 2009-06-10 17:31:02 EDT
Matěj,

we are getting off-topic here, but anyway:

In my blog post I have described the situation in Fedora 8. Both XDMCP and automatic login has been added to the rewritten GDM _much_ later. And even now I am not sure whether gdm is able to

- use all the command-line options supported by the X server in the gdm config file (thus being completely unusable for a multi-seat setup). AFAIK they are trying to wrap _some_ of the X server options into a gdm-specific envelope instead of supporting just plain old "command and all its arguments" in a single configuration string,

- use a simple "login/password" dialog instead of the user list (or having to click "other" with a disabled user list), thus being essentially unusable in a network environment with 2000+ users,

- run as an XDMCP-only server without a local X server (altough I haven't verified that this problem still exists in recent versions)

- run more than one X server (for a multi-seat setup).

Anyway, thanks for fixing this bug!
Comment 21 Matěj Cepl 2009-06-11 08:34:09 EDT
(In reply to comment #20)
> Anyway, thanks for fixing this bug!  

Just doin' my job, Ma'm!

(anyway, I hope bugs for all this missing features are on bugzilla.gnome.org, or at least here, with you as a reporter or on CC list, right?)
Comment 22 Jan "Yenya" Kasprzak 2009-06-11 10:25:00 EDT
For the reference, I am on the Cc list of about nine gdm bugs now.

See also gdm being mentioned in the Fedora multiseat feature page:

https://fedoraproject.org/wiki/Features/Multiseat
Comment 23 Matěj Cepl 2009-06-12 09:41:39 EDT
(In reply to comment #22)
> See also gdm being mentioned in the Fedora multiseat feature page:
> 
> https://fedoraproject.org/wiki/Features/Multiseat  

No binding promise, but we really hope that you should be all set with Fedora 12 once it is done. Hopefully.
Comment 24 Fedora Update System 2009-06-19 09:33:27 EDT
xorg-x11-xdm-1.1.6-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.