Bug 190141 - sshd port forwarding stopped working as of glibc-2.3.6-3.
sshd port forwarding stopped working as of glibc-2.3.6-3.
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-04-27 18:48 EDT by Jeff Groves
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-03 08:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Putty ssh client logging (33.60 KB, application/octet-stream)
2006-05-02 01:29 EDT, Jeff Groves
no flags Details
Log file from running -ddd parameter with sshd (15.46 KB, text/plain)
2006-05-02 01:30 EDT, Jeff Groves
no flags Details
Testcase (631 bytes, text/plain)
2006-05-02 07:41 EDT, Tomas Mraz
no flags Details

  None (edit)
Description Jeff Groves 2006-04-27 18:48:57 EDT
Description of problem:
Previously, on the same machine, I was able to create ssh connections to my
server and use the port forwarding to access systems on my local network.  

After my last yum update on April 21 where glibc-2.3.6-3 was installed (along
with a few other things), sshd port forwarding now longer works.  I now get the

Forwarded connection refused by server: Administratively prohibited [open failed]

Version-Release number of selected component (if applicable):

How reproducible:
Errors out every time now.

Steps to Reproduce:
1.  yum update to get glibc-2.3.6-3 and other items
2.  try to use the port forwarding when connecting to the updated server
3.  receive error message 
Actual results:
Forwarded connection refused by server: Administratively prohibited [open failed]

Expected results:

I expected to be able to connect to other machines on my local network as I have
been able to until April 21.

Additional info:

I check the open-ssh project web site and found no references to this issue there.
Comment 1 Tomas Mraz 2006-04-28 11:33:32 EDT
I'm sorry but I cannot reproduce this problem here.

Which client version do you use?

Could you try to run the server with sshd -ddd and attach the debug output here?
Could you do the same on client? (ssh -vvv ....)
Comment 2 Jeff Groves 2006-04-29 19:24:19 EDT
This is actually using PuTTy version 0.58 as my client.  I've also used the
current development tip version of PuTTy with the same negative results.

I'll put together th requested -ddd and -vvv output files tomorrow when I have a
spare moment -- might be kind of hard to get the -vvv files or the equivalent
since I'm using PuTTy though.  We'll see.


Jeff G.
Comment 3 Jeff Groves 2006-05-02 01:29:09 EDT
Created attachment 128467 [details]
Putty ssh client logging
Comment 4 Jeff Groves 2006-05-02 01:30:25 EDT
Created attachment 128468 [details]
Log file from running -ddd parameter with sshd
Comment 5 Jeff Groves 2006-05-02 01:34:12 EDT
Upon further investigation, this issue where forwarding isn't happening is when
I specify the host using its DNS name.  If I specify an IP address, then the
forwarding works OK.

I would be the first to point a finger at my DNS configuration, but this all
worked just fine before I did the April 21 yum update.  Also, DNS name
resolution to IP address works fine on the server and the client machines with
other applicaitons.


Jeff G.
Comment 6 Tomas Mraz 2006-05-02 03:32:36 EDT
What prints 'host webcam2.test.org' when you run it on the server?
Comment 7 Jeff Groves 2006-05-02 05:41:45 EDT
Please note that I text replaced my domain name with "test.org" log files that I
posted after I ran the tests.  I made this change for privacy reasons.  With
that being said, I've run the test that you requested and again made the same
change afterwards:

$ host webcam2.test.org
webcam2.test.org has address

This DNS name translation to IP address is correct.
Comment 8 Tomas Mraz 2006-05-02 07:41:32 EDT
Created attachment 128478 [details]

Can you try compiling and running this testcase as './testgai webcam2.test.org
Comment 9 Éric Brunet 2006-05-02 13:45:59 EDT
I don't think it is a problem of sshd, but of the glibc.
I have similar problems with other programs when using glibc-2.3.6-3 on my i386 fc4:

scp -P 22 somehost:x .     fails with a "System error"
scp       somehost:x .     succeeds
scp -P 22 someip:x .       succeeds
(somehost is the full qualified host name, someip is number.number.number.number)
(note that ssh works in all configuration)

ncftp somehost             fails with a "segmentation fault"
ncftp someip               succeeds

yum list (or update, etc)  fails with "Cannot find a valid baseurl for repo..."
                           obviously, it could not fetch the mirror list.

nxclient    (from NoMachine) fails also with a "System error"

All of this works nicely if I downgrade glibc to 2.3.5-10.3

I don't have any named running. My resolv.conf contains three nameserver lines
and a "search localdomain" line. "host somehost" works correctly, and
"./testgai webcam2.test.org 80" gives "getaddrinfo succeeded".

I am back to using glibc-2.3.5 to have a usable system. I can make some more
test, but I need to "upgrade" glibc, make the tests and downgrade it. It would
be nice if you could batch the tests you ask me to do...
Comment 10 Tomas Mraz 2006-05-02 13:58:02 EDT
-> glibc
Comment 11 Jeff Groves 2006-05-02 14:32:28 EDT
Results of testcase execution below:

  $ ./testgai webcam2.test.org 80
  getaddrinfo succeeded


Jeff G.
Comment 12 Jakub Jelinek 2006-05-03 08:32:22 EDT
Just remove nisplus from your nsswitch.conf.

*** This bug has been marked as a duplicate of 186592 ***
Comment 13 Jeff Groves 2006-05-03 19:17:42 EDT
I can confirm that removing the nisplus entries from my /etc/nsswitch.conf file
is a valid work-around to resolve this issue.


Jeff g.

Note You need to log in before you can comment on or make changes to this bug.