Bug 190161 - Yum crashes with python undefined symbol in libxml2mod.so
Summary: Yum crashes with python undefined symbol in libxml2mod.so
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i586 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-28 12:59 UTC by Jørgen Thomsen
Modified: 2014-01-21 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 17:08:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jørgen Thomsen 2006-04-28 12:59:33 UTC
Description of problem:
Same problem as in 160373 when upgrading from RH8 to Fedora5. Everything looks
normal in the upgrade log.

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /usr/lib/python2.4/site-packages/libxml2mod.so: undefined symbol:
xmlTextReaderGetParserColumnNumber

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.2 (#1, Feb 12 2006, 03:59:46)
[GCC 4.1.0 20060210 (Red Hat 4.1.0-0.24)]

-rw-r--r-- 1 root root 388790 Feb 12 01:59
/usr/lib/python2.4/site-packages/libxml2mod.a

These versions seem to match.



Version-Release number of selected component (if applicable):

from FC5 DVD

How reproducible:

always

Steps to Reproduce:
1. yum
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jørgen Thomsen 2006-04-28 17:08:23 UTC
The cause has been found: an older version of libxml2.so in /usr/local/lib was
apparently found before the upgraded version in /usr/lib



Note You need to log in before you can comment on or make changes to this bug.