Bug 190188 - Update Firefox Window Icon
Update Firefox Window Icon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-04-28 12:36 EDT by n0dalus
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 02:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Current Icon (left) and Official Icon (right) (11.89 KB, image/png)
2006-04-28 12:36 EDT, n0dalus
no flags Details

  None (edit)
Description n0dalus 2006-04-28 12:36:30 EDT
Since some time around December 2004 (according to the ChangeLog on the spec
file), Fedora has been shipping a default.xpm logo that is some what uglier than
the official logo. I'm not sure why it was introduced (firefox.xpm in the spec),
but the screenshot attached shows that the official branded xpm distributed with
the source tarball (mozilla/other-licenses/branding/firefox/default.xpm) is much
nicer.

In the spec file, instead of:
%{__cp} %{SOURCE23} $RPM_BUILD_ROOT%{ffdir}/chrome/icons/default/default.xpm
%{__cp} %{SOURCE23} $RPM_BUILD_ROOT%{ffdir}/icons/default.xpm

We should copy the xpm out of mozilla/other-licenses/branding/firefox in the source.
Comment 1 n0dalus 2006-04-28 12:36:30 EDT
Created attachment 128365 [details]
Current Icon (left) and Official Icon (right)
Comment 2 Andy Burns 2006-04-29 10:48:05 EDT
Sorry if I'm hi-jacking your bug, but the thunderbird icon is even uglier, just
a default X icon, at least someone posted a workaround ...

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=177823

Comment 3 Leo 2006-08-20 08:32:23 EDT
Fedora is really slow at fixing small bugs. That's why many of us just stop
reporting them.
Comment 4 Matthew Miller 2006-08-20 11:00:54 EDT
Fedora is really fast at fixing many bugs, but there are several serious and
high-profile problem spots. "Anything related to Firefox" is unfortunately one
of those spots.
Comment 5 Christopher Aillon 2006-09-27 02:50:07 EDT
This was actually fixed a bit ago.

Note You need to log in before you can comment on or make changes to this bug.