Bug 1902276 - pgcli fails to build with Python 3.10: SystemError: PY_SSIZE_T_CLEAN macro must be defined for '#' formats
Summary: pgcli fails to build with Python 3.10: SystemError: PY_SSIZE_T_CLEAN macro mu...
Keywords:
Status: CLOSED DUPLICATE of bug 1919789
Alias: None
Product: Fedora
Classification: Fedora
Component: pgcli
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dick Marinus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-27 14:49 UTC by Tomáš Hrnčiar
Modified: 2021-02-21 06:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-21 06:23:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-27 14:49:56 UTC
pgcli fails to build with Python 3.10.0a2.

=================================== FAILURES ===================================
_______________________ test_obfuscate_process_password ________________________

    @pytest.mark.skipif(platform.system() == "Windows", reason="Not applicable in windows")
    @pytest.mark.skipif(not setproctitle, reason="setproctitle not available")
    def test_obfuscate_process_password():
>       original_title = setproctitle.getproctitle()
E       SystemError: PY_SSIZE_T_CLEAN macro must be defined for '#' formats

tests/test_main.py:28: SystemError


https://docs.python.org/3.10/whatsnew/3.10.html#id2

The PY_SSIZE_T_CLEAN macro must now be defined to use PyArg_ParseTuple() and Py_BuildValue() formats which use #: es#, et#, s#, u#, y#, z#, U# and Z#. See Parsing arguments and building values and the PEP 353.
https://docs.python.org/3.10/c-api/arg.html#arg-parsing
https://www.python.org/dev/peps/pep-0353
https://bugs.python.org/issue40943

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01797201-pgcli/

For all our attempts to build pgcli with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/pgcli/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-27 15:12:43 UTC
This sounds like a problem in python-setproctitle (has tests commented out, so it built fine).

Comment 2 Ben Cotton 2021-02-09 15:28:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 3 Fedora Admin user for bugzilla script actions 2021-02-17 00:07:46 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 4 Fedora Admin user for bugzilla script actions 2021-02-20 12:05:44 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 5 Dick Marinus 2021-02-21 06:23:26 UTC

*** This bug has been marked as a duplicate of bug 1919789 ***


Note You need to log in before you can comment on or make changes to this bug.