Bug 190234 - Clustat times out with 8 nodes and 24 IP services
Clustat times out with 8 nodes and 24 IP services
Status: CLOSED DUPLICATE of bug 182454
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-28 18:52 EDT by Henry Harris
Modified: 2009-04-16 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 13:06:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henry Harris 2006-04-28 18:52:30 EDT
Description of problem: On an eight node cluster, we have configured 24 IP 
services.  On most of the nodes, clustat times out and does not show the IP 
services.  At most on two of the eight nodes clustat will show the IP services.


Version-Release number of selected component (if applicable):
rgmanager-1.9.46-0

How reproducible:
Every time

Steps to Reproduce:
1. Configure an 8 node cluster with 24 IP services
2. Start the cluster
3. Run clustat on each node
  
Actual results:
On at least 5 or 6 of the nodes clustat times out

Expected results:
Clustat to return complete status on all nodes

Additional info:
Comment 1 Dennis Preston 2006-05-03 15:14:52 EDT
Clustat also times out on 1 node of a 3 node cluster with 51 IP services 
configured. The test reproduction and environment info are exactly the same as 
reported by Henry with the exception being number of nodes and services.
Comment 2 Lon Hohberger 2006-05-08 13:07:12 EDT
I expect to have an initial pass at a fix by tomorrow morning.  With some luck,
I will have it today.
Comment 3 Henry Harris 2006-05-08 13:26:58 EDT
Sounds good, thanks.
Comment 4 Henry Harris 2006-05-08 15:03:33 EDT
Here's some additional info.  We have found that if we boot all nodes with a 
smaller number of VIPs and then configure additional VIPs on a running cluster 
we can get more VIPs to run than if we boot all the nodes with the total 
number of VIPS already configured.  Also, is the fix you are working on going 
to address the other bugs I've opened on rgmanager?  It looks like they may 
all be related.
Comment 6 Henry Harris 2006-05-09 11:38:11 EDT
Thanks, Lon.  We'll try it right away and let you know what happens.
Comment 7 Lon Hohberger 2006-05-12 13:06:20 EDT

*** This bug has been marked as a duplicate of 182454 ***

Note You need to log in before you can comment on or make changes to this bug.