Bug 190240 - PCI-X bus numbers 0x40,41,42 not detected
PCI-X bus numbers 0x40,41,42 not detected
Status: CLOSED DUPLICATE of bug 190239
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-28 20:40 EDT by mike jaskowiak
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 21:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mike jaskowiak 2006-04-28 20:40:43 EDT
Description of problem: Gigabyte GA-2cewH server board bios maps the pci-x 
bridges/bus numbers to 0x40,41,42. They are not detected after instilation 
ergardless of type of cards in them, ie storage,nic. The lspci and proc pci 
dir util only lists up to bus 4.  

The admin guide refered to us the device command to pass the module name to 
anaconda in the kickstart but it did not detail the options switch, only 
listing some base io addresses. It also refered to passing these parms to the 
kernel (thru device >> anaconda??). I also saw this in the manual cd install 
but don't remember the man page and component it refered to in user/doc/...

Sooo, how do you force anaconda to scan ALL pci bus numbers.

Version-Release number of selected component (if applicable):
Redhat EL AS 2 update 2 with online updates.

How reproducible:always on that motherboard


Steps to Reproduce:
1.install RH EL AS4 u2 with / without cards in the PCI-X slots ON THAT 
MOTHERBOARD.  (no bios update or response yet from Gigabyte)
2.Aften install check lspci or proc pci and observe the pci-x slots are not 
detected.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-04-28 21:18:57 EDT

*** This bug has been marked as a duplicate of 190239 ***

Note You need to log in before you can comment on or make changes to this bug.