Bug 190249 - Wrong auto-mount of fat32 partition at boot time
Wrong auto-mount of fat32 partition at boot time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-29 05:20 EDT by Juergen Wieczorek
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 08:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Wieczorek 2006-04-29 05:20:00 EDT
System:
Fedora Core 5, kernel-2.6.16-1.2096_FC5, autofs-4.1.4-19
SELinux = disabled.

I have a fat32 which should be auto-mounted with owner 'user' at startup, but
Fedora Core 5 only mounts it for 'root' , disregarding my entry in /etc/fstab.

This is the respective entry in my /etc/fstab:
/dev/hda7 /mnt/windows_e vfat auto,user,exec,umask=0022 0 0

If I unmount the parition (as root), I can remount it as user anytime.
Additionally, I can set fstab options uid=500, gid=500 to have it mounted for me
as the prime user.

The above fstab entry has worked for FC3 without any problems, now FC5 screws it
up - but why?
Comment 1 Jeffrey Moyer 2006-04-29 15:29:26 EDT
First, you've filed this bug against the wrong component.  Autofs is an
automounter implementation which operates off of its own set of configuration
files (auto.master, etc.).

Next, You specify "auto" in your mount options.  If you don't want the partition
to be mounted at boot, you should specify "noauto".  I don't know why the
behaviour has changed.  I'll re-assign this to util-linux for you.

Regards,

Jeff
Comment 2 Juergen Wieczorek 2006-04-30 04:54:14 EDT
Sorry if I hanve not made that point clear enough:
I want the fat32 partition to be auto-mounted at boot time, but for owner='user'
and _not_ for 'root'.
That has worked with FC3 and now doesn't work with FC5.
Comment 3 Karel Zak 2006-06-02 08:19:31 EDT
Please, read the mount man page. 

/dev/hda7 /mnt/windows_e vfat auto,user,exec,umask=0022 0 0

This entry means that arbitrary user is able to mount the device. At boot time
it's user "root" who mounts the device. The option owner='username' allows to
mount the device by user if he is the owner of the device.

I think you should remove 'auto' option and mount the device by hand (or by
automounter or whatever) under non-root user.


Note You need to log in before you can comment on or make changes to this bug.