Bug 1902618 - python-pyside2 fails to build with Python 3.10: Py_REFCNT= needs to be replaced with Py_SET_REFCNT
Summary: python-pyside2 fails to build with Python 3.10: Py_REFCNT= needs to be replac...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyside2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1960117 1969107 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1968805 1968835 1968868 1969197
TreeView+ depends on / blocked
 
Reported: 2020-11-30 08:02 UTC by Tomáš Hrnčiar
Modified: 2021-06-15 20:14 UTC (History)
7 users (show)

Fixed In Version: python-pyside2-5.15.2-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-15 20:14:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-30 08:02:18 UTC
python-pyside2 fails to build with Python 3.10.0a2.

/sources/shiboken2/libshiboken/sbkstring.cpp:250:23: error: expression is not assignable
        Py_REFCNT(ob) = 1;
        ~~~~~~~~~~~~~ ^
1 error generated.

https://docs.python.org/3.10/whatsnew/changelog.html#id11

bpo-39573: Convert Py_REFCNT() and Py_SIZE() macros to static inline functions. They cannot be used as l-value anymore: use Py_SET_REFCNT() and Py_SET_SIZE() to set an object reference count and size. This change is backward incompatible on purpose, to prepare the C API for an opaque PyObject structure.
https://bugs.python.org/issue39573

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01805997-python-pyside2/

For all our attempts to build python-pyside2 with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-pyside2/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-30 10:10:15 UTC
Victor, please take a look.

Comment 2 Victor Stinner 2020-11-30 10:47:46 UTC
I'm working on a fix: https://src.fedoraproject.org/rpms/python-pyside2/pull-request/7

Comment 3 Victor Stinner 2020-11-30 11:20:52 UTC
I reported the issue to Qt upstream (PySide project): https://bugreports.qt.io/browse/PYSIDE-1436

Comment 4 Richard Shaw 2020-12-05 13:04:17 UTC
Upstream is having a very active discussion on the fix so I would rather wait for them than apply the patch which just makes it "build". 

Hopefully they'll provide a patch (or something that I can make a patch from) and we won't have to wait until the next patch release.

Comment 5 Ben Cotton 2021-02-09 15:29:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 6 Miro Hrončok 2021-06-04 20:14:05 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 7 Ben Beasley 2021-06-07 15:17:16 UTC
Looks like upstream didn’t come through in time for the mass rebuild. The last update in the discussion was

> It is under test, and there are a few critical bugs with debug builds.

on 2021-05-13.

The proposed patch set is https://codereview.qt-project.org/c/pyside/pyside-setup/+/348390; the notes say:

> Unfortunately, there are a couple of bugs remaining which
> need further investigation. (Built with debug mode)
> Some bugs are infinite loops.
> 
> The test script breaks with unicode errors, which needs
> fixing, before continuing on this.

What do you think should be done?

Comment 8 Miro Hrončok 2021-06-07 22:58:45 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 9 Miro Hrončok 2021-06-08 10:57:10 UTC
*** Bug 1960117 has been marked as a duplicate of this bug. ***

Comment 10 Miro Hrončok 2021-06-08 11:31:11 UTC
*** Bug 1969107 has been marked as a duplicate of this bug. ***

Comment 11 Richard Shaw 2021-06-11 02:42:22 UTC
Nope, no fix from upstream as of yet.

Comment 12 Richard Shaw 2021-06-14 14:49:29 UTC
Porting pyside2 to Python 3.10 is beyond me, anyone else care to take a stab at it? It doesn't seem like upstream is in any hurry.

Comment 13 Miro Hrončok 2021-06-14 15:12:32 UTC
Let's see if https://codereview.qt-project.org/c/pyside/pyside-setup/+/348390 is any better than the status quo. I can build it in Copr and see if the dependent packages build.

Comment 14 Miro Hrončok 2021-06-15 20:14:18 UTC
Built. I've triggered builds for the dependent packages.


Note You need to log in before you can comment on or make changes to this bug.