Bug 1902704 - clufter: FTBFS in Fedora rawhide: No matching package to install: 'jing'
Summary: clufter: FTBFS in Fedora rawhide: No matching package to install: 'jing'
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: clufter
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1968785 (view as bug list)
Depends On: 1892855 2003596
Blocks: F34FTBFS F35FTBFS F35FailsToInstall F36FTBFS F36FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-30 13:06 UTC by Tomáš Hrnčiar
Modified: 2021-10-05 08:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-05 08:30:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-30 13:06:24 UTC
Description of problem:
Package clufter fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.77.2-9.fc33

Steps to Reproduce:
koji build --scratch f34 clufter-0.77.2-9.fc33.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/clufter

Problem: conflicting requests
- nothing provides relaxngDatatype needed by jing-20151127-8.fc32.noarch

Comment 1 Fedora Release Engineering 2020-12-06 04:22:50 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 34.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-01-25).

A week before the mass branching of Fedora 35 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 33 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

Comment 2 Jan Pokorný [poki] 2020-12-06 12:07:01 UTC
Thanks for the heads up.

Need to take a look what is going on with relaxngDatatype.

Keeping needinfo for the time being, as a reminder.

Comment 3 Ben Cotton 2021-02-09 15:29:15 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 4 Miro Hrončok 2021-06-04 20:15:47 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 5 Miro Hrončok 2021-06-07 23:00:09 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 6 Miro Hrončok 2021-06-08 11:13:55 UTC
*** Bug 1968785 has been marked as a duplicate of this bug. ***

Comment 7 Miro Hrončok 2021-07-26 09:02:08 UTC
Any update here?

Comment 8 Ben Cotton 2021-08-10 12:49:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 9 Miro Hrončok 2021-08-23 11:10:37 UTC
The build problem is: No matching package to install: 'jing'

poki, have you had a chance to look at this?

Comment 10 Miro Hrončok 2021-08-30 22:39:53 UTC
Friendly bump.

Comment 11 Miro Hrončok 2021-09-09 18:19:30 UTC
And another one.

Comment 12 Mamoru TASAKA 2021-09-14 05:22:59 UTC
Just FYI:

* jing binary rpm was built from jing-trang:
  https://src.fedoraproject.org/rpms/jing-trang
  https://koji.fedoraproject.org/koji/packageinfo?packageID=11296

* looks like jing-trang FTBFS on Fedora 33 development era, then jing-trang firstly got orphaned
  because of "NEW" status for FTBFS bug, then got retired on Fedora 34 because of long orphaned
  status.
  ref:
  https://bugzilla.redhat.com/show_bug.cgi?id=1863905

* Now clufter FTBFS from Fedora 34 development era.

Comment 13 Miro Hrončok 2021-09-29 14:44:54 UTC
The final freeze for F35 starts in less than a week on Tuesday 2021-10-05. Setting severity to urgent.

Comment 14 Miro Hrončok 2021-10-04 12:39:30 UTC
The package was now orphaned via https://pagure.io/fesco/issue/2666

I'll go ahead and retire it on F35+ to avoid broken deps at GA. It can be retired after F35 is released is anybody is interested.

Comment 15 Miro Hrončok 2021-10-04 15:50:23 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/clufter by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 16 Miro Hrončok 2021-10-05 08:30:24 UTC
$ koji list-pkgs --show-blocked  --tag f35 --quiet --package clufter
clufter                 f35                                      jpokorny        [BLOCKED]

$ koji list-pkgs --show-blocked  --tag f36 --quiet --package clufter
clufter                 f36                                      orphan          [BLOCKED]


Note You need to log in before you can comment on or make changes to this bug.