Bug 190272 - KBuildSycoca crashes with SIGSEGV
KBuildSycoca crashes with SIGSEGV
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-29 17:28 EDT by Alex Tucker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 15:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Legacy menu description for Crossover Office (273 bytes, text/xml)
2006-05-04 15:19 EDT, Alex Tucker
no flags Details

  None (edit)
Description Alex Tucker 2006-04-29 17:28:10 EDT
Description of problem:

After the recent update to KDE on logging in or any other time kbuildsycoca
needs to be run, instead it crashes with a SIGSEGV.

Version-Release number of selected component (if applicable):

kdelibs-3.5.2-0.1.fc5

How reproducible:

Always.  Have removed .kde directory and even created a test user to see if
there's anything I can do to stop it.

Steps to Reproduce:
1. Log in with a KDE session
  
Actual results:
The second item on the splash screen starts flashing, then a crash dialog
appears underneath, which must be "Ok"ed before being able to continue.

Expected results:
No crash.

Additional info:
Here's a traceback after installing kdelibs-debuginfo:

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912496332992 (LWP 4568)]
[KCrash handler]
#5  0x0000003ead80fb6f in QGDictIterator::toFirst ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#6  0x0000003ead80fbff in QGDictIterator::QGDictIterator$base ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#7  0x0000003eac618168 in VFolderMenu::excludeItems (this=)
    at /usr/lib64/qt-3.3/include/qdict.h:104
#8  0x0000003eac61d82c in VFolderMenu::mergeMenu (this=0x12fd1a0, 
    menu1=0x1367fb0, menu2=0x194b3e0, reversePriority=false)
    at vfolder_menu.cpp:190
#9  0x0000003eac61f376 in VFolderMenu::processMenu (this=0x12fd1a0, 
    docElem=@0x7fffff9252e0, pass=0) at vfolder_menu.cpp:1390
#10 0x0000003eac625389 in VFolderMenu::parseMenu (this=0x12fd1a0, file=)
    at vfolder_menu.cpp:1611
#11 0x0000003eac6283e8 in KBuildSycoca::build (this=0x6715d0)
    at kbuildsycoca.cpp:384
#12 0x0000003eac62892b in KBuildSycoca::recreate (this=0x6715d0)
    at kbuildsycoca.cpp:519
#13 0x0000003eac62911a in kdemain (argc=) at kbuildsycoca.cpp:924
#14 0x0000000000407521 in launch (argc=3, _name=0x64a468 "kbuildsycoca", 
    args=0x64a490 "", cwd=0x0, envc=1, envs=0x64a4a5 "", reset_env=false, 
    tty=0x0, avoid_loops=false, 
    startup_id_str=0x64a4ae "ferrari.floop.org.uk;1146340248;82332;4566_TIME0")
    at kinit.cpp:639
#15 0x0000000000407d00 in handle_launcher_request (sock=8) at kinit.cpp:1205
#16 0x0000000000408205 in handle_requests (waitForPid=4565) at kinit.cpp:1406
#17 0x0000000000408bf1 in main (argc=2, argv=0x7fffff926570, 
    envp=0x7fffff926850) at kinit.cpp:1807
#18 0x0000003ea961d084 in __libc_start_main () from /lib64/libc.so.6
#19 0x00000000004049b9 in _start ()
#20 0x00007fffff926828 in ?? ()
#21 0x0000000000000000 in ?? ()
Comment 1 Ngo Than 2006-05-04 12:53:55 EDT
You mean this problem also happens with a new user? If not, does this problem 
still appear if you remove .config directory in your home directory before 
starting KDE?

Please attach the output of "rpm -qa | grep kde" and the all files in
/etc/xdg/menus, /etc/profile.d/

Thanks
Comment 2 Alex Tucker 2006-05-04 15:17:20 EDT
Thanks for the pointers; by a process of elimination I tracked down the issue to
a file under /etc/xdg/menus from an installation of Crossover Office, namely
/etc/xdg/menus/applications-merged/cxlegacy.menu.  Removing this stops
kbuildsycoca from crashing.

For completeness, I've attached the contents of this file, which seems to be
in-spec reading http://standards.freedesktop.org/menu-spec/latest/ar01s07.html

I've also checked the contents of the directory the <LegacyDir> element points
to and even removed all .desktop entries in there, but whenever the
cxlegacy.menu file is present, kbuildsycoca crashes.

Removing the file is a workable fix, so I'll consider this issue resolved with
the caveat that kbuildsycoca is still buggy if it crashes on an apparently well
formed menu file.

Thanks for helping out,
Alex.
Comment 3 Alex Tucker 2006-05-04 15:19:42 EDT
Created attachment 128622 [details]
Legacy menu description for Crossover Office

Seemingly causes kbuildsycoca to crash.

Note You need to log in before you can comment on or make changes to this bug.